Qlik Community

QlikView Security & Governance

Discussion Board for collaboration on QlikView Security and Governance.

Announcements
The #1 reason QlikView customers adopt Qlik Sense is a desire for a modern BI experience. Read More
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor II
Contributor II

Access Point. Application opening and signing loop

Hi everybody,

Im not expert on Qlikview administration, but have to do some.

I have just published a new application on the webserver. I can see it on the Access Point portal.  But when I try to open it, im redirected to the login page...and cant go further. The login page displays in loop.

When I remove publishing / publish again this app, at first opening, The APP is loading for some seconds before redirecting to login page.

I can open any other application, but cant open this new one.

Any idea of how to troubleshoot this ?

Usually, I set some NTFS permissions on the server to restrict who views and who doesnt.

Actually, as Im in debug mode, permissions are set with Full access to Domain users.

 

Thank you for help

 

1 Solution

Accepted Solutions
Highlighted
Digital Support
Digital Support

Check the Settings\Document Properties\Opening tab settings and the Initial Data Reduction... setting along with the Strict Exclusion settings, be sure those are unchecked, reload again without the Section Access piece of the load script and ensure the NTFS rights on the posted app in the User Docs folder allows users access.  The fact it is visible on the AccessPoint page should mean access is correct unless in the Settings\Document Properties\Server tab settings the checkbox to check Section Access for AccessPoint is unchecked there, which would show the app even if Section Access would prevent them from opening it...  Only things of which I can think.

Here is Help link to Section Access and below that a Design Blog post on Section Access that may be useful too.

https://help.qlik.com/en-US/qlikview/April2019/Subsystems/Client/Content/QV_QlikView/Security.htm

https://community.qlik.com/t5/Qlik-Design-Blog/A-Primer-on-Section-Access/ba-p/1465766

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.

View solution in original post

4 Replies
Highlighted
Contributor II
Contributor II

Looks like this new APP is a copy of an old one with internal view restrictions. Those restrictions has been removed in the new APP.

//$(include=Restriction_file.txt);

If I put them back removing the "//", that works after reloading.

If I comment that line with // and reload again, i still got the APP unavailable.

I guess our developpers have missed something when removing those restrictions. There is probably some settings left somewhere in the advanced menus.

I will check that with them.

 

 

 

Highlighted
Contributor II
Contributor II

Hi All,

can't figure out the issue. I request your help. Let me explain.

We have a QVD file which is used by a MODEL file which is use by an APP file.  The APP file is published on the Access point.

On the old application APP_OLD, there are security restrictions. Some people can see the entire APP content and some others can see some sheets only. That depends of LDAP groups members of.

Restrictions have been set with a security tab in the MODEL file + a text file in the same folder as the the MODEL file.

There is no issue at the moment on the APP_OLD.

 

The new application APP_NEW is quiet similar but supposed to remove the view restrictions.

So, developpers have removed the security tab in the MODEL file + removed the text file in the same folder as the MODEL file.

 

BUT now, i can't open the APP_NEW from the Access Point. I am still prompted with login as long as I click on the new APP.

If I put back the security tab in the MODEL file+ the text file in the same folder,  then I can pen the APP_NEW application.

So, I guess there is something else in the MODEL or APP file that refers to the security restrictions, but cant find what, and where.

Any body could help me with that ?

 

Thank you.

 

 

Highlighted
Digital Support
Digital Support

Check the Settings\Document Properties\Opening tab settings and the Initial Data Reduction... setting along with the Strict Exclusion settings, be sure those are unchecked, reload again without the Section Access piece of the load script and ensure the NTFS rights on the posted app in the User Docs folder allows users access.  The fact it is visible on the AccessPoint page should mean access is correct unless in the Settings\Document Properties\Server tab settings the checkbox to check Section Access for AccessPoint is unchecked there, which would show the app even if Section Access would prevent them from opening it...  Only things of which I can think.

Here is Help link to Section Access and below that a Design Blog post on Section Access that may be useful too.

https://help.qlik.com/en-US/qlikview/April2019/Subsystems/Client/Content/QV_QlikView/Security.htm

https://community.qlik.com/t5/Qlik-Design-Blog/A-Primer-on-Section-Access/ba-p/1465766

Regards,
Brett

To help users find verified answers, please do not forget to use the "Accept as Solution" button on any post(s) that helped you resolve your problem or question.
I now work a compressed schedule, Tuesday, Wednesday and Thursday, so those will be the days I will reply to any follow-up posts.

View solution in original post

Highlighted
Contributor II
Contributor II


@Brett_Bleess wrote:

Check the Settings\Document Properties\Opening tab settings and the Initial Data Reduction... setting along with the Strict Exclusion settings, be sure those are unchecked, reload again without the Section Access piece of the load script [...]


This is it 👍!

Im a system admin so those Qlikview settings don't make any sense to me 😱 . I would never clik on that setting alone.

Thank you Brett