Qlik Community

QlikView Security & Governance

Discussion Board for collaboration on QlikView Security and Governance.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

richard01
Not applicable

Access Point (QV11) doesn't show documents

Hello,

We did build our own authentication. Through webticket we receive QV ticket and link to the Access Point. Within the Access Point we do see the correct Username logged in, but no documents are shown.

We do use DMS with DSC ODBC. Within the SQLServer we have users and groups. This part is working, because when i search in the QEMC on the username, i see the group and QV documents the user is allowed to open. So connection between DSC ODBC en Qlikview seems to be ok. Please see attached screenshots.

When i login with this user, i see the username in top of the Accesspoint screen, but the documents i did see in QEMC aren't shown in the Access point.

What can be the reason these documents are not displayed?

Thank you in advance.

Richard

Tags (2)
1 Solution

Accepted Solutions
Support
Support

Re: Access Point (QV11) doesn't show documents

OK, that might be your problem. It is hard to tell for sure by looking at the attached images, but normally you but the domain prefix there. So, in what I can tell you need QlikViewUsers.

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
10 Replies
Support
Support

Re: Access Point (QV11) doesn't show documents

Hi,

What is your Prefix set at?

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
richard01
Not applicable

Re: Access Point (QV11) doesn't show documents

Hello,

In QEMC in authentication tab the prefix is  CUSTOM\.

Thank you for your time and help !

Best regards,

Richard

Support
Support

Re: Access Point (QV11) doesn't show documents

OK, that might be your problem. It is hard to tell for sure by looking at the attached images, but normally you but the domain prefix there. So, in what I can tell you need QlikViewUsers.

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
richard01
Not applicable

Re: Access Point (QV11) doesn't show documents

I did change this setting and put QlikViewUser\{username} as login. I do see the Qlikview document available in the Access Point !!   Only when i want to open this document i get a Windows Authentication Popup every time i want to open a Qlikview document. But when i cancel this windows popup the Qlikview document is loaded and displays the contents.

Do you have any suggestion / direction to solve or looking for?

Thank you for helping me out !!

Best regards,

Richard

Support
Support

Re: Access Point (QV11) doesn't show documents

You have to set all the Qlikview folders in IIS to Anonymous and then in the QvAjaxZfc folder you need to set authenticate.aspx to windows authentication.

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
richard01
Not applicable

Re: Access Point (QV11) doesn't show documents

I change the settings, but this didn't change the behaviour. I will install fiddler and look if i see something happening.

Thank you again for your help showing the documents !!

Best Regards,

Richard

Not applicable

Re: Access Point (QV11) doesn't show documents

Does it apply also to IAS licence? There are no CALs hence no QlikViewUsers and authentication off.

richard01
Not applicable

Re: Access Point (QV11) doesn't show documents

Hello Andrzej,

Sorry, I don't know if this also applies IAS license. Perhaps someone of Qliktech can tell you.

Richard

Support
Support

Re: Access Point (QV11) doesn't show documents

Hi,

QlikView IAS runs in anonymous mode and must be publically accessible without authentication (on the public Internet), that is, it must not be placed behind a firewall. No QlikView client can access QlikView IAS

So, the answer is no. This server has to run in anonymous mode.

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.