Qlik Community

QlikView Security & Governance

Discussion Board for collaboration on QlikView Security and Governance.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Asking for password while no section access in the script

HI all,

I'v created a QlikView application and it asks for a username & password when it's opened on the server. (I don't mean the first box where you need your Active Directory username & password)

However there is no Section Access in the script. Also no hidden scripts available.

Please advise. Are there any other hidden options?

Best regards,
Arjan

15 Replies
Not applicable

Re: Asking for password while no section access in the script

Have you set up authentication and security correctly in the QV Management Console, both in the QlikView Server and Webserver? Is it only happening for that QlikView document or does it happen in all of them? Does the document have section access configured in the hidden script (Script Editor --> File)? Does the problem occur both when opening the app in the Ajax (web) client and using the desktop app?

MVP
MVP

Re: Asking for password while no section access in the script

Maybe a binary load statement?

Not applicable

Re: Asking for password while no section access in the script

Random thoughts....

* are the tick boxes on the opening tab of the document properties ticked that QlikView should be checking security?

* did the document have Section Access in it at one point... personally I have found that QlikView does seem to remember previous Section Access even after you remove all data, a refresh seems to be needed to remove the SA data?

* is the security on the server set to be Windows and is this stopping you somehow?

As I said some random thoughts (basically things I would start to look at if I had the problem)

Not applicable

Re: Asking for password while no section access in the script

First of all thank you for the quick response..

It only happens for one application. There is no hidden script and it only occurs on the webserver. Wuth AJAX & IEpl ugin. However on the client I don't get any box.

Not applicable

Re: Asking for password while no section access in the script

No binary load statement in the script. Thanks anyway.

Not applicable

Re: Asking for password while no section access in the script

What do you mean with refresh? I assume it's not the refresh of data but some other refresh.

Can you please explain it?

* All tick boxes are checked on the security tab of the sheet. So the users should have access, right ?

* It should didn't have had a section access as far as I know.

* The security on the server works fine for all other applications.

jerrysvensson
Valued Contributor II

Re: Asking for password while no section access in the script

Can you take a print screen and add it here?

Not applicable

Re: Asking for password while no section access in the script

jerrysvensson
Valued Contributor II

Re: Asking for password while no section access in the script

Strange, it looks exactly like a Section Access login dialog.

Simplest solution is to create a new app and copy the script and layout from this one.

Community Browser