Qlik Community

QlikView Security & Governance

Discussion Board for collaboration on QlikView Security and Governance.

Not applicable

Failing Windows Authentication without Prompting

Hi Experts

We have implemented Windows Authentication and it works fine for users in the Windows domain configured in the DSC. Also, when a user connects to AccessPoint and is not authenticated, AccessPoint prompts for the Windows username and password. This is standard behaviour.

Does anyone know how to disable this behaviour? What we want is for failed authentication to show a message on a web page rather than prompting for the Windows username and password.

Thanks

Al.

6 Replies
jaimeaguilar
Valued Contributor II

Re: Failing Windows Authentication without Prompting

Hi,

There's an option in QMC where you can tell QlikView to not prompt for Windows user and password. Instead it appears a login legend appears at the top right corner. If the user that is logged in to Windows has no QlikView License, he/she will not be able to view any application in Access point

login.png

you can activate this option in QMC > System > QlikView Web Servers > Authentication > Login:

login2.png

This option will not ask for user name or password it will just pass credentials from windows to QlikView without prompting, but user has to click on login link (first image),

Hope this helps,

regards

aveeeeeee7en
Valued Contributor III

Re: Failing Windows Authentication without Prompting

Hi Al McEwan

You can set Automatic Logon for each User and your user will never face this Authentication issue.

Please See the Attached.

It's a 2 step process:

1. Open Internet Explorer> Go to Tools Option> Select Internet Options from the List> Go to Security Tab> Select Local Intranet> Down you'll see Custom Level Button> Click on it> Security Settings Window Appears> Scroll down to Botton> Select Second Last Option i.e. "Automatic Logon with Current Logon and Password-OFF"> Ok > Ok.

2. Same Steps to be Followed for Trusted Sites:

Open Internet Explorer> Go to Tools Option> Select Internet Options from the List> Go to Security Tab> Select Trusted Sites> Down you'll see Custom Level Button> Click on it> Security Settings Window Appears> Scroll down to Botton> Select Second Last Option i.e. "Automatic Logon with Current Logon and Password-OFF"> Ok > Ok.

Hope it Works for You.

Not applicable

Re: Failing Windows Authentication without Prompting

Thanks for the suggestion but we want automatic logon, I just want to manage the failed logins. Also I cannot mess with the IE settings.

Not applicable

Re: Failing Windows Authentication without Prompting

That may be a good option, thanks.

Employee
Employee

Re: Failing Windows Authentication without Prompting

Hi Al,

This login you are seeing is controlled by Windows and not Qlik. If you are using IIS I would think you could do some type of redirect for the 401 errors

Bill

Not applicable

Re: Failing Windows Authentication without Prompting

Yup, that is what I thought. So I guess there is no option to influence this through custom QV.

Community Browser