Qlik Community

QlikView Security & Governance

Discussion Board for collaboration on QlikView Security and Governance.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
datanibbler
Esteemed Contributor

OMIT fields in SA

Hi,

I have been trying to do this for some time before my involuntary holiday. Now I'm at it again:

- In one of my apps (personell), there are currently no names visible - for the simple reason that I can only have the names in none of my apps or in all, and the latter is to be avoided.

Now, however, I'd like to introduce names - but with OMIT option in the Section_access so that the names are loaded into the DataModel in the first place for a very restricted group of people only.

In principle, that is no problem: You just use three fields instead of two in the section_access:

- ACCESS (USER or ADMIN)

- NTNAME (in this instance, >> domain\firstname.lastname <<)

- OMIT (name of the field that should not be loaded for this user)

=> Thus, every user gets several lines in the underlying Excel_list (where I list all the entries for the SA) - one per field, at least two
      (first_name, last_name)

<=> For some reason, it does not work: I just tried introducing two of those OMIT_fields for myself - still with ADMIN access - and I checked the spelling of the field_names several times. It is the same everywhere - and I can view the fields from the Section_access, I can view my logon and see that those two fields are listed as OMIT fields - still I can see those names.

Can anyone help me out here?

Thanks a lot!

Best regards,

DataNibbler

Tags (1)
18 Replies
MVP
MVP

Re: OMIT fields in SA

Have you checked- 'Intial Data Reduction Based on Section Access' (Settings->Document Properties->Opning) and uncheck 'Admin Override Security' in the security tab ?

datanibbler
Esteemed Contributor

Re: OMIT fields in SA

Hi tresesco,

I have checked those fields in the dialog - I haven't unchecked the override one.

<=> Wouldn't that be quite dangerous? I'm not working on the "live" app, of course, but still I wouldn't like to lock myself out...

Best regards,

DataNibbler

MVP
MVP

Re: OMIT fields in SA

Hi

Rule #1 when developing section access script - ALWAYS make a backup (just in caseSmiley Happy)

Regards

Jonathan

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
datanibbler
Esteemed Contributor

Re: OMIT fields in SA

Hi tresesco,

I don't know, it might have to do with the way I do this:

- I have a table "SA_temp" that consists of two parts:

  -  The first part is an Inline_table with just two users

  -  Then I concatenate a LOAD from an Excel file - with the same fields of course.

  => Finally, I do a RESIDENT LOAD from that with the keyword "Section access" (written just like that) in front (no
       blank inbetween) and I actually drop the temp_table - but that, too, is for some reason not done.

MVP
MVP

Re: OMIT fields in SA

Has checking the 'Initial...' resolved the issue? If you are admin, you can go and reset your 'admin override security' option even it is unchecked at the first place. That doesn't lock you outside(if I am not greatly mistaken).

datanibbler
Esteemed Contributor

Re: OMIT fields in SA


Hi,

no, unchecking it has not resolved the issue - not yet anyway.

I guess I know why the table "SA_temp" was not dropped - I had it before the keyword "Section_application" - I just moved it and I'm trying now.

However, the basic issue remains - the SA seemingly does not work.

P.S.: I'll be ... it seems to be working now! Can it really have been "hanging" on that > DROP TABLE < command that was not executed?

datanibbler
Esteemed Contributor

Re: OMIT fields in SA


O_O

no, I was looking at the wrong set of listboxes ;-) The fields from SA_temp disappeared now

<=> the issue remains: In spite of entering those two name fields as OMIT_fields for myself, I can see them.

MVP
MVP

Re: OMIT fields in SA

Try to load it like:

Section Access;

Load * Inline [

.....

];

Load * From <Excel Source>;

Section Application;

....

//Then no need to drop the table.

datanibbler
Esteemed Contributor

Re: OMIT fields in SA

Hi tresesco,

unfortunately, that does not help things - I can do this and it seems to work fine, but to no avail - I can still see those two names ...

I really don't know what might be going wrong here. That is problematic because if I cannot make sure the names are properly protected - e.g. not available to users who shouldn't see them - I cannot put them into the dataModel in the first place, or I would have to duplicate all the base_data I draw from the database, once with and once without names.

Well, maybe we'll find out what's going wrong after all.

Best regards,

DataNibbler

Community Browser