Qlik Community

QlikView Security & Governance

Discussion Board for collaboration on QlikView Security and Governance.

sureshqv
Esteemed Contributor III

SECTION ACCESS

hi all,

i hve created section access to my document lik below..

Section Access;

LOAD * INLINE [

    ACCESS, USERID, PASSWORD, %LEVEL

    ADMIN, ADMIN, ADMIN, *

    USER, USER, USER, Project1

    USER1, USER1, USER1, Project2

];

SECTION Application;

when  i opened with ADMIN it is shwng all projects  THAT IS OK

but wen i open with user AND user1 ... it alsow opening all projcets.....

i want to open user only project1

user -project2

1 Solution

Accepted Solutions

Re: SECTION ACCESS

Keep Blank in the field %LEVEL will solve your problem.

13 Replies
balrajahlawat
Esteemed Contributor

Re: SECTION ACCESS

Check this option...

see the attachment..

Re: SECTION ACCESS

Try with this by capital words on the field name and in the model as well as.

Section Access;

LOAD * INLINE [

    ACCESS, USERID, PASSWORD, %LEVEL

    ADMIN, ADMIN, ADMIN, *

    USER, USER, USER, PROJECT1

    USER1, USER1, USER1, PROJECT2

];

SECTION Application;

Or in your model as well for the field like use of UPPER function

Load

Upper (%LEVEL) as %LEVEL

...

..

From Location

Regards

Anand

sureshqv
Esteemed Contributor III

Re: SECTION ACCESS

BALRAJ.. I HVE TRIED EVEN THOUGH IT IS SHWNG SAME...

balrajahlawat
Esteemed Contributor

Re: SECTION ACCESS

Put all the information in CAP as suggested by Anand

sureshqv
Esteemed Contributor III

Re: SECTION ACCESS

NICE ANAD......THNX IT WORKS EXACTLY.....BUT WEN OPENNG WITH ADMIN IT IS SHWNG prjoect1 and project2 only.

i hve prj1

prj2

prj3

prj4

prj5

Re: SECTION ACCESS

Check settings for ADMIN use * other wise keep blank there.

Regards

Anand

Re: SECTION ACCESS

Keep Blank in the field %LEVEL will solve your problem.

Re: SECTION ACCESS

Correct. This * will only match the values that are present in the %LEVEL field in your SectionAccess table, not those additional values in the %LEVEL field in Section Application.

Note that this behavior is ok in QV Desktop. In a published document on the server, the story is different again. In the AccessPoint, everybody is a USER. And while a blank link field will let ADMINs enter this document in QV Desktop, it will get them kicked out if you enable 'Strict Exclusion'.

Best,

Peter

sureshqv
Esteemed Contributor III

Re: SECTION ACCESS

IF I WANT TO GIVE PERMISSION TO user to  access project1 and project2  how can i give?

Community Browser