Qlik Community

QlikView Security & Governance

Discussion Board for collaboration on QlikView Security and Governance.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Employee
Employee

Section Access and reduction over 2 fields - ADMIN vs USER problem on the Access Point

Hello,

I have successfully developed an application where Section Access is used, to reduce data over two fields.

From prior discussions I understood that there are no ADMIN users on the Access Point, these ADMIN lines in Section Access should be ignored on the AP and are just for the QlikView Client.

My problem now is, that these information about the ADMIN on the AP does not come true.



// sales data

Daten: 

LOAD DKUN_VERTRIEBSLEITER_ID & '|' & DKUN_VERKAUFSORGANISATION_ID as AuthID,

           DKUN_VERKAUFSORGANISATION_ID,

           DKUN_VERTRIEBSLEITER_ID,

           UMSATZ

FROM

(ooxml, embedded labels, table is Tabelle1);

// user authorization table

Source_Authorization_Table:

LOAD VERTRIEBSLEITER & '|' & VKORG as %AuthID,

           USER,

           VERTRIEBSLEITER,

           VKORG

FROM

(ooxml, embedded labels, table is Tabelle1);

// connection between the sales data and the authorization table

Connection_AuthTable_Data:

LOAD DKUN_VERTRIEBSLEITER_ID & '|' & DKUN_VERKAUFSORGANISATION_ID as AuthID,

DKUN_VERTRIEBSLEITER_ID & '|' & DKUN_VERKAUFSORGANISATION_ID as %AuthID Resident Daten;

  

LOAD DKUN_VERTRIEBSLEITER_ID & '|' & DKUN_VERKAUFSORGANISATION_ID as AuthID,

'<ANY>'   & '|' & DKUN_VERKAUFSORGANISATION_ID as %AuthID Resident Daten;

LOAD DKUN_VERTRIEBSLEITER_ID & '|' & DKUN_VERKAUFSORGANISATION_ID as AuthID,

DKUN_VERTRIEBSLEITER_ID & '|' & '<ANY>'  as %AuthID Resident Daten;

  

LOAD DKUN_VERTRIEBSLEITER_ID & '|' & DKUN_VERKAUFSORGANISATION_ID as AuthID,

'<ANY>'   & '|' & '<ANY>'  as %AuthID Resident Daten;

Section Access;

LOAD * INLINE [

ACCESS, NTNAME, USER

USER, QTSEL\ACB, USER1

USER, QTSEL\QWE, USER2

USER, QTSEL\QWS, USER3

USER, QTSEL\QWD, USER4

];

Section Application;



This script works fine, the problem which I have comes when I put a ADMIN User in the Section Access:


Section Access;

LOAD * INLINE [

ACCESS, NTNAME, USER

ADMIN, QTSEL\ACB, USER5

USER, QTSEL\ACB, USER1

USER, QTSEL\QWE, USER2

USER, QTSEL\QWS, USER3

USER, QTSEL\QWD, USER4

];

Section Application;


In the QlikView Client I am identificated as ADMIN and see everything which is linked to USER5 - which is correct.


BUT when I put the application on the server and enter the Application, I still see the same view as of the QlikView Client with USER5 and NOT USER1 - as I thought.


Can anybody give me a clue?

Kind Regards,

Christian

2 Replies
chauhans85
Esteemed Contributor

Re: Section Access and reduction over 2 fields - ADMIN vs USER problem on the Access Point

as I can see the above section access iis only NTname security for users access.

You have not mention two fields on which you want to Reduce Data.i

Think section access code would be like below

Section Access;

Load

upper(ACCESS) as ACCESS, upper(NTNAME) as NTNAME, upper(DKUN_VERTRIEBSLEITER_ID &'|'&DKUN_VERKAUFSORGANISATION_ID)  as AuthID;

LOAD * INLINE [

ACCESS, NTNAME, DKUN_VERTRIEBSLEITER_ID ,DKUN_VERKAUFSORGANISATION_ID

ADMIN, QTSEL\ACB, Somevalue,Somevalue

USER, QTSEL\ACB, Somevalue,Somevalue

USER, QTSEL\QWE, Somevalue,Somevalue

USER, QTSEL\QWS, Somevalue,Somevalue

USER, QTSEL\QWD, Somevalue,Somevalue

];

Section Application;

Employee
Employee

Re: Section Access and reduction over 2 fields - ADMIN vs USER problem on the Access Point

Thanks Sunil for your fast reply.

I have used the article to implement Section Access:

Data Reduction Using Multiple Fields

So in the front I am using just one field to reduce data, but in the background there is a mapping table which restrict both fields DKUN_VERKAUFSORGANISATION_ID and DKUN_VERTRIEBSLEITER_ID.

I am just wondering about the usage of ADMIN vs USER, especially on the Access Point.

Do you have any idea about this issue?

Community Browser