Qlik Community

QlikView Security & Governance

Discussion Board for collaboration on QlikView Security and Governance.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Section Access causing incorrect data to appear

In our QlikView document we have two tabs that represent different Reporting Markets. Swapping to the tab forces QlikView to choose the appropriate reporting market with no input from the user. These two tabs are split into the same four business segments.


Our issue comes in when a user is restricted through Section Access to be able to only see one of the four business segments. If there is no data for that business segment in the second tab, when you switch over to that tab instead of showing $0 (Which is how it is normally shown if you don't have restricted access) it shows the data from tab 1.

Has anyone come across this issue, and if so what did you find to be the best solution?

Thank you in advance for the help!

3 Replies
MVP
MVP

Re: Section Access causing incorrect data to appear

That's hard to tell without knowing how your data model and data looks like and what exactely you are doing when entering another tab.

I assume you are using an action to make a selection which isn't anymore possible after applying the section access data reduction, hence the selection is actually cleared.

If possible, create & upload a small sample QVW that demonstrates your issue, if you need further help.

Not applicable

Re: Section Access causing incorrect data to appear

Stefan,

I'll try to work on getting a sample QVW that replicates the issue but in essence yes it seems that QlikView realizes there isn't any data there and clears the selection. Unfortunately, we need it to not clear the selection so I'm trying to see if there may be any workarounds to this.

Thank you for the quick response!

MVP & Luminary
MVP & Luminary

Re: Section Access causing incorrect data to appear

It's not quite clear for me but it sounds that you hadn't enabled the option "strikt exclusion". Without these option is section access only a kind of usability and not really restricting data to the user-rights. Take a look here: Section Access: Strict Exclusion and here for more helpful informations and examples: Section Access.

- Marcus