Qlik Community

QlikView Security & Governance

Discussion Board for collaboration on QlikView Security and Governance.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
krishnamraju513
Contributor

Section Access with NTName doesn't work in QMC .

Hi All ,

I've written a Section Access Script in my QVW Document . But I dont know how to run this one in QMC .

What are the steps involved in running my QVW with Section Access with NTNAME in it in QMC .

My Section Access Script :

SECTION Access;

LOAD ACCESS,

     NTNAME

FROM

..\APPS\Book1.xlsx

(ooxml, embedded labels, table is Sheet3);

SECTION Application;

LOAD NTNAME,

     Name

FROM

..\APPS\Book1.xlsx

(ooxml, embedded labels, table is Sheet2);

I've enabled these options .

Capture.JPG

Please help me on this

5 Replies

Re: Section Access with NTName doesn't work in QMC .

You need to add the user which runs the server services to your section access table as ADMIN and make sure that these also had access-rights to ..\APPS\Book1.xlsx.

- Marcus

Re: Section Access with NTName doesn't work in QMC .

What do you mean by "running my QVW ... in QMC"? You can reload your document from the QlikView Management Console (by first applying the essential steps that Marcus suggested), or you can open your document in the AccessPoint. The two are pretty much unrelated.

If you get errors trying to do something with your document on the server, please post them here.

Best,

Peter

krishnamraju513
Contributor

Re: Section Access with NTName doesn't work in QMC .

Hello Marcus ,

First of all thanks for the suggestion you gave me .

I've added user who runs the server services to my section access table as ADMIN .

After that, when i reload the QVW in QMC, I got an error .

I'm attaching the Error log file . Please have a look .

Please help me . As i'm completely new to the reloading and distribution process .

Re: Section Access with NTName doesn't work in QMC .

What did the script-log say? If it's not enabled you could enable it in the document properties in tab general.

- Marcus

Re: Section Access with NTName doesn't work in QMC .

Apparently, the QlikView Distribution Service (or more specifically the reload engine) is unable to open your document for script execution. This is usually caused by the QDS not having proper permissions to open/save/mess with the document.

The name of the document indicates that you are experimenting with Section Access. Did you add the Windows account that is running the QlikView services to the NTNAME column in Section Access?

Peter

Community Browser