Qlik Community

QlikView Security & Governance

Discussion Board for collaboration on QlikView Security and Governance.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
vicky_qv
New Contributor III

Section access not working in QLIKSENSE 3.0

Hi

The value 'USER' in section access 'ACCESS' field is not working in QLIKSENSE 3.0. I am getting 'Access denied error'.

If I use 'ADMIN',then it is working fine.

Thanks,

Vignesh U.

1 Solution

Accepted Solutions
MVP
MVP

Re: Section access not working in QLIKSENSE 3.0

Oh.. You are using domain id with USERID. That doesn't work. You have to probably use NTNAME instead, like:

ACCESS, NTNAME, GROUP

ADMIN,DOMAINNAME\SA_SCHEDULER,*

USER,DOMAINNAME\QLIKSENSE1,GROUP1

USER,DOMAINNAME\QLIKSENSE2,GROUP2

USER,DOMAINNAME\QLIKSENSE,*

];

10 Replies
vicky_qv
New Contributor III

Re: Section access not working in QLIKSENSE 3.0

Re: Section access not working in QLIKSENSE 3.0

Could you please share the section  access code ..will have a look

vicky_qv
New Contributor III

Re: Section access not working in QLIKSENSE 3.0

Hi Avinash,

Below is the code. (Domain name is our client's one). My login is with 'DOMAINNAME\QLIKSENSE'. Changing to lowercase is also not working.

Section access;

Load * inline [

ACCESS, USERID, GROUP

ADMIN,INTERNAL\SA_SCHEDULER,*

USER,DOMAINNAME\QLIKSENSE,*

];

Section application;

Star is *;

Thanks.

MVP
MVP

Re: Section access not working in QLIKSENSE 3.0

When you use "*" in section access it actually means 'All the values of field that are mentioned in section access field'. In your case you have not mentioned any Group value explicitly. That's why USER access doesn't get any value to allow to access to. Try putting like:

ACCESS, USERID, GROUP

ADMIN,INTERNAL\SA_SCHEDULER,*

USER,DOMAINNAME\QLIKSENSE1,GROUP1

USER,DOMAINNAME\QLIKSENSE2,GROUP2

USER,DOMAINNAME\QLIKSENSE,*

];

Then your users DOMAINNAME\QLIKSENSE will get all mentioned group members i.e - Group1 and Group2.

vicky_qv
New Contributor III

Re: Section access not working in QLIKSENSE 3.0

Hi Tresesco,

Actually some of the users are having some values in 'Group' field. But I did not show those users in the above table.

Thanks,

Vignesh U.

MVP
MVP

Re: Section access not working in QLIKSENSE 3.0

Have you used Upper() to convert both match your section access values and Group field?

vicky_qv
New Contributor III

Re: Section access not working in QLIKSENSE 3.0

No, Upper() is not used. Both table values have been entered in capital letters.

MVP
MVP

Re: Section access not working in QLIKSENSE 3.0

Oh.. You are using domain id with USERID. That doesn't work. You have to probably use NTNAME instead, like:

ACCESS, NTNAME, GROUP

ADMIN,DOMAINNAME\SA_SCHEDULER,*

USER,DOMAINNAME\QLIKSENSE1,GROUP1

USER,DOMAINNAME\QLIKSENSE2,GROUP2

USER,DOMAINNAME\QLIKSENSE,*

];

shraddha_g
Honored Contributor III

Re: Section access not working in QLIKSENSE 3.0

I am facing same issue with version 2.2.4.

Sometime it works with USER and sometimes I have to change it to ADMIN

Community Browser