Qlik Community

QlikView Security & Governance

Discussion Board for collaboration on QlikView Security and Governance.

Not applicable

problem with section application.

Hi,
I have a problem with section application.
I have 2 filters:

In the section access:

Filter the "Pub_Company" (each ntname get permissions to different Pub_Company name)

In the section application:

Filter by tabs.(each ntname get permissions to different tabs in the document)

The Pub Company filter dosn't work:

If i filter "pub_company" for one ntname, all the other ntnames can't see the  "pub_company" too.

Do you know what is the problem?

SCRIPT:

section Access;

LOAD UPPER(ACCESS) AS ACCESS,

UPPER(NTNAME) AS NTNAME,

PUBCOMPANY as [Pub_Company]

FROM

(ooxml, embedded labels, table is Sheet1);

SECTION APPLICATION;

LOAD UPPER(NTNAME) AS NTNAME,

UPPER(SH01) AS SH01,

UPPER(SH02) AS SH02,

UPPER(SH03) AS SH03,

UPPER(SH04) AS SH04,

UPPER(SH05) AS SH05

FROM

(ooxml, embedded labels, table is Sheet1);

dim_publishers:

LOAD * Inline [publisher_id,Pub_Company]

1,ARG

2,SPA

3,DSP

4,DDS

];

sheet1:

ACCESS

NTNAME

PUBCOMPANY

SH01

SH02

SH03

SH04

SH05

USER

CYDOORCOM\a

ARG

1

1

0

0

0

USER

CYDOORCOM\c

SPA

1

0

0

1

1

USER

CYDOORCOM\c

DSP

1

0

0

0

1

USER

CYDOORCOM\d

DSP

1

1

1

0

1

1 Reply
buzzy996
Honored Contributor II

Re: problem with section application.

i think this is replica of the other post,any how..

use this,

for access,publisher_id as user name and PASSWORD as password

for example here username as 1 and password as y1

Section Access;

Load * Inline

[ACCESS,publisher_id,PASSWORD

USER,1,Y1

USER,2,Y2

USER,3,Y3

USER,4,Y4];

Community Browser