Qlik Community

Ask a Question

Scalability

Announcements
QlikWorld May 10-12, Online and Free! REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
Daniel_Larsson
Employee
Employee

QV Scalability Tools (QV10,QV11,QV12)

This package (referred to as QVScalabilityTools) contains a complete set of tools for easy creation, execution and analyzing of load/performance tests and regression tests.

 

QlikView documents to help analyze result and log files(This was previously included in this package):Scalability Results Analyzer

 

Older versions of the tool can be found here: Tool for easy creation of load/performance tests of QlikView (v.10 and 11)

Tools for Qlik Sense can be found here: Qlik Sense Scalability Tools (Sense v2.0, v2.1, v2.2, v3.0, v3.1)

QlikView Benchmarking tests: QlikView 12 Hardware Benchmarking Package and QlikView 11 Hardware Benchmarking Package

 

Note: Using windows built-in unzip functionality will not allow the .exe to launch unless unblocking zipped package first (properties -> unblock).

 

Included parts are:

  • Standalone application for creating a JMeter script
  • Support files for launching the script by utilizing the JMeter engine (JMeter installed is a pre-requisite)
  • Documentation on how to use the package

Changelog 1.2.6->1.2.7

  • NTLM support removed due current solution broken and lack of a new secure solution.
  • Small updates for static content, for future product releases.

2019-08-26

Documentation updates due to:
- New recommended JMeter version (4.0)
- Changes to the licensing for the Oracle Java implementation (seehttps://www.oracle.com/technetwork/java/javase/overview/oracle-jdk-faqs.html)
- Open-source Java Development Kits (JDKs) have been verified for use with JMeter and the QlikView Scalability Tools

Changelog 1.2.5->1.2.6

  • Added support for QlikView 12.50 and 12.20SR10

Changelog 1.2.4->1.2.5

  • Added support for QlikView 12.30

Changelog 1.2.3->1.2.4

  • Added support for JMeter 4.0 and Java 9.
  • Bugfixes for regression testing
  • Added actions: Select Excluded, Select All, Select Possible
  • Added support for 12.20 SR3

Changelog 1.2.2->1.2.3

  • Bugfix for export to excel action
  • Added transfer state (bookmark) support for document chaining
  • GUI: Template selection more accurately show supported Qv versions

Changelog 1.2.1->1.2.2

  • Bugfixes, make sure minimum amount of selections are respected in certain corner cases

Changelog 1.2->1.2.1

  • Improved performance for high throughput scenarios

Changelog 1.1 -> 1.2

  • Improved assertions logic to show faulty actions as errors
  • Change JMeter template scripts to use groovy instead of beanshell
  • New prerequisites:
    • JMeter version 3.0
    • Java 64-bit JRE 8

 

Your use of QVScalabilityTools will be subject to the same license agreement between you and QlikTech for QlikView Server. QlikTech does not provide maintenance and support services for QVScalabilityTools, however please check QlikCommunity for additional information on use of these products.

 

PLEASE NOTE:

The supported versions of Java are 8 and 9. Supported version of JMeter are 3.0 and 4.0, but not 3.2

134 Replies
Daniel_Larsson
Employee
Employee
Author

Vahidenur Culha Flechl wrote:

I haven't really understood how this scalibility tool handles QlikView Server Clusters. If I have a Cluster with 4 nodes, should I run  four different tests on these nodes seperately? Or can I add all the nodes into the configuration and analyse them in one test?

Hi you can run them in one test, then you link the performance counters together using the Testlogmeta.txt file, you can access this from within the QVD generator.

kristy_wedel
Contributor II
Contributor II

I'm getting an error when I try to compare results from the regression analyzer. Has anyone else received this error before?

Daniel_Larsson
Employee
Employee
Author

I haven't had a read problem, but I would check this, in this order:

  1. Is it the files in (ToolRoot)\RegressionResults\(TestName)-(QvVersion)-(Timestamp) you're comparing?
  2. Can you access the file manually, e.g. open with notepad?
  3. Is the file corrupt in some way?
kristy_wedel
Contributor II
Contributor II

Thanks Daniel. It seems when I run my tests one of the ending tags is missing from the output xml </requestedobject>. It happens each time I run a test.

PawelF
Employee
Employee

Sorry for late reply.

If I understand correctly this happens for just one requested object, the other ones in the script are working fine.

Could you please give us information in what type of object is failing for you (ListBox, MultiBox, ...)?

Also information on which version of QlikView are you testing on can be helpful.

This should help us investigate.

kristy_wedel
Contributor II
Contributor II

This occurred in a script making static selections from a listbox and multibox. It also occurred in another script when making a selection from a straight table.

adrian_costar
Contributor III
Contributor III

Hi Sebastian,

I'm having the same issue. The XML file is not generated correctly. The same script runs fine in the previous version.

Also the server version and the "open document" action are not recognised:

Version 1.1

<?xml version="1.0" encoding="UTF-8" ?>

<testresult testname="Regresion - op in 02 Regr1 - Simple" QVSversion= "11.20.13405.0409" Document="OP IN 02 Indirect sales analysis report Regr1.qvw" timeStamp="2017-02-17-040557">

  <requestedobject action="OD #2" id="OP IN 02 Indirect sales analysis report Regr1.qvw" inputValue="" threadIteration="1" testLoop="0">

  <returnedobject id="LB615_430655325" type="LB" help="ListBox" mode="hidden">

.....

Version 1.2

<?xml version="1.0" encoding="UTF-8" ?>

<testresult testname="Regresion - op in 02 Regr1 - Simple" QVSversion= "NoVersion" Document="OP IN 02 Indirect sales analysis report Regr1.qvw" timeStamp="2017-02-17-054624">

    <requestedobject action="null" id="null" inputValue="null" threadIteration="1" testLoop="0">

        <returnedobject id="LB615_430655325" type="LB" help="ListBox" mode="hidden"></returnedobject>

....

Many Thanks,

Adrian

9717023463
Partner
Partner

Hi ,

I am new to scalability testing and while collecting logs I am facing a issue that Failed to get QVS list From Localhost(server name) .

Please find the screenshot below. What could be the issue ?

snip.PNG

Daniel_Larsson
Employee
Employee
Author

Hi,

First, it's not recommended to run a scalability test towards the local machine since the tool will use a few GB of memory which might effect the performance of the engine.

Secondly, there's a "Log" tab which possibly might contain information of why logs cannot be collected.

The reason that you don't have access rights to read the webserver configuration, or don't have one.

Since you're running locally it might be easier to collect the log files manually or semi-manually.

Semi-manually: Click the "+" under "Paths to log files" and enter the paths where log files are saved, then press the "scan" button to the right within the "Paths to log files" box.

Using the servername "localhost" might also get you into problems connecting the sever info and performance counters in the analyzer app, make sure to correctly edit the meta-data om qvd-generator to have these connected properly to the servername in performance counter log files and server info xml (response time would still show correctly though).

9717023463
Partner
Partner

Hi Daniel,

Thanks for your reply.

One more thing I want to know is that how do we come to know that the application has been connected to the tool. Like in case of qliksense there is connect to app button which tells us that if the application is connected to tool or not and ready to use. In this case I am not able to identify whether my app is connected to the tool or not.