Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
Daniel_Larsson
Employee
Employee

Qlik Sense Scalability Tools

This package (referred to as Qlik Sense Scalability Tools) contains a complete set of tools for easy creation, execution and analysis of load/performance tests.

This tool is now deprecated and will not receive any further updates, please use the Qlik Sense Enterprise Scalability Tools instead.

Supported versions of Qlik Sense: all 2020, all 2021, 2022-aug

 

Included parts are:

  • Standalone application for creating and executing a simulation script
  • Documentation on how to use the package
  • Regression analyzer
  • Benchmarking package
  • App evaluator package


QlikView and Qlik Sense documents to help analyze result and log files (previously included in this package) can be found here :https://community.qlik.com/docs/DOC-15451

 

Troubleshooting

For help to troubleshoot connection problems, please review Appendix A of the documentation or Connection Troubleshooting Tips

 

Change log

v5.17.0

  • Add support for Qlik Sense May 2022 release
  • Add support for Qlik Sense Aug 2022 release

v5.16.0

  • Add support for Qlik Sense Feb 2022 release

v5.15.0

  •  Add support for Qlik Sense Nov 2021 release

v5.14.0

  • Add support for Qlik Sense Aug 2021 release

(See Readme.txt for changes in earlier versions of the tool.)

 

Your use of Qlik Sense Scalability Tool will be subject to the same license agreement between you and Qlik for your Qlik Sense License. Qlik does not provide maintenance and support services for the Qlik Sense Scalability Tool, however please check QlikCommunity for additional information on use of these products.

Labels (2)
199 Replies
Daniel_Larsson
Employee
Employee
Author


Tell me how you can change and increase this waiting parameter (15000 m s), and how to fix the duration of execution (GlobalSearch) for uncached data, so that you can then compare it with the duration of cached data in the Scalability Results Analyzer application, and see the difference?


 

15000 is not the length of the timeout, it's the error code that comes from engine that the search took too long. https://help.qlik.com/en-US/sense-developer/November2021/Subsystems/EngineJSONAPI/Content/models-nxl...
i.e. LOCERR_SEARCH_TIMEOUT = 15000 which we translated to to clear text in the error message.

In other words this is a timeout server side, not tool side.

benoithervochon
Partner - Contributor III
Partner - Contributor III

Hello, after reading the Deprecation Notice, is there a way to migrate existing scenarios to the 'new' Qlik Sense Enterpise Scalability Tools ?

Thx

¯\_(ツ)_/¯
Daniel_Larsson
Employee
Employee
Author

Hi, no sorry currently there doesn't exist any migration tool for the scripts.

And just to re-iterate, there's ample time for migration, these tools will continue to receive updated for the entire year of 2022, after that they will likely continue to work, just not receive any updates.

My suggestion for migration path is to start doing new scripts with the "new" tools get familiarized if you haven't used them before. Then start migrating older scripts still in use at that point (e.g. cache-warming scripts etc) after having some experience with the new tools.

The tools do not have 100% feature parity with each other, so please report things you have an actual need for on the enterprise tools page in case it does not support it.

julian_rodriguez
Partner - Specialist
Partner - Specialist

Hello Experts,

 

We have this scenario configured, but everytime that the test try to connect the 5th session, it fails. 

¿What could we doing wrong?

julian_rodriguez_1-1657818645365.png

 

julian_rodriguez_0-1657818530749.png

 

Daniel_Larsson
Employee
Employee
Author


@julian_rodriguez wrote:

We have this scenario configured, but everytime that the test try to connect the 5th session, it fails. 

¿What could we doing wrong?

 


Usually it's a different error message, but since you are using NTLM (i.e all sessions using same user) this is most likely a licensing issue and not a script/ configuration issue. Most likely the NTLM user you are using (which is the one running the tool) has user access defined. User access only allows for 5 "simultaneous" logins and you are trying to run 20.

You have a few options to mitigate this.
1. Change to using header auth and simulate different users (each needs a way to consume tokens either through user acess or login access)
2. Change to using login access type which comsumes tokens in a bit different way

login access token consumption:
https://help.qlik.com/en-US/sense-admin/May2022/Subsystems/DeployAdministerQSE/Content/Sense_DeployA...

SwapneelGolapkar
Contributor III
Contributor III

Hi 

i am facing issues with header authentication, can someone help as to where can we mention the Header value in the settings ?

The proxy setup is correct as am using scalability 1.3 setup there am able to test the connection.

but in 5.16 version - unable to find place holder for Header value. - this field is missing for me.

 

nagarwal
Partner - Contributor II
Partner - Contributor II

Hello Sacalability Team,

Could you please help me out ?

I have installed Qlik Sense Enterprise Scalability tool on my server machine but when I try to open the tool I am getting as Tool stopped working. I have attached screen shot.
When I tried to install it on user machine and tried to connect to server hostname it is giving error as websocket connected, but authentication failed. Attached the screen shot for the same.
Could you please help me out why this issue is coming and how should I resolve this

janyf
Partner - Contributor III
Partner - Contributor III

Hello 

Could someone please advise how to do testing with more than 5 users ? 
We are getting parallel session limit exceeded error.

We tried prefix method of user generation and also usersfromlist, but results are same.

Best regards

Jan Farkas

sri_c003
Partner - Creator II
Partner - Creator II

@Daniel_Larsson 

We had used the scalability tool before and we see it being replaced by the new enterprise version of the same. We installed this new one, and face an issue with being unable to find the authentication method that was present before - header based authentication.

In all over deployments we use header based authentication and this was the same method we had used with the earlier versions of the tool.

Could you please add support to the tool for header based authentication.

Older tool:

sri_c003_0-1712256305999.png

New tool:

sri_c003_1-1712256345895.png

Qlik supported authentication methods:

sri_c003_2-1712256383659.png

 

Daniel_Larsson
Employee
Employee
Author

Hi,

You can read about how to use "header" authentication  on page 32 in the documentation, basically you set it to ws and configure the header.