3 Replies Latest reply: Dec 30, 2013 2:11 AM by Nathan Simonson RSS

    List Box Selections

      Hi,

       

      I've concatenated about 7 data sources and have produced a report which enables a multi-box selection based on product and a list box on broker.  All 7 data sources have got these similar fields.

       

      When I select on a product, I don't have the 'selectable' broker going straight to the top of the list box.

       

      I've selected the 'State' option under Sort however this does not seem to fix the issue.

       

      Is there another way to have the selectable options move to the top?

       

      Regards,

      Nathan

        • Re: List Box Selections
          Suryanto Susanto

          Hi Nathan,

          could you attach the qvw file so i can try to help u'r porblem.

           

          Regards,

          • Re: List Box Selections
            Rohit Koul

            Hi Nathan,

            A quick test as it is auto way of qlikview Enviroment you just delete that List Box create again or creat a New sheet and create a New List box and check.

            else You have several other options in sort like sorting with Expression can easily come with solution or try others one by one.

             

            if not solved you can attach a sample and you will get a solution for sure

              • Re: List Box Selections

                Hi all,

                 

                Thanks for the quick response.

                 

                I'd figured out what the issue was and it looks as though it was because I was using an expression for the list box:

                 

                If(Len(Trim(PLR_BCH_BRANCHNAME))=0,'<No Broker>',PLR_BCH_BRANCHNAME)

                 

                I didn't realise but using expressions hinders Qlikview's ability to properly sort the possible selections within a list box.

                 

                Unless there's something else I'm unaware of?

                 

                Regards,

                Nathan