14 Replies Latest reply: Feb 26, 2014 5:31 AM by Felipe Carrera RSS

    RAM usage high after upgrade QVS 11.2 SR4 / 5

    Felipe Carrera

      Hi

      after we upgraded from QV 11 SR2 to QV 11.2 SR4 (and then SR5) end of November 2013, we experienced a high use of RAM, without any active user and/or session. It fluctuates around 110 +/- 8 GB achieving or surpassing working set Limits. Total RAM in the QVS is 128 Gb

      According to the QMC Statistics, we have 16 loaded documents, in the Access Point we have document sizing approx. 25 GB

       

      This issues originates that users cannot open large documents (above 5 Gbs to 9 Gbs) and that the Performance of smaller documents less than 1Gb is very slow. Making filters or using Charts take a lot of time or is practically impossible

       

      Do you have experienced similar issues after the upgrade? With QVS 11 SR2 everything was fine, now authentication, license lease and Performance are not working well

       

      Besides, are there current Tools for measuring object, data model, expression,etc , performance in qlikview documents?
      I used the qlikview load Simulator but i cannot see anything wrong there

      Thanks for any comments on this.

      Felipe

        • Re: RAM usage high after upgrade QVS 11.2 SR4 / 5

          Hi Felipe,

           

          Did you find any solution for this.

          For me response of dashboard is even slower with SR5 and crashing (becoming not responding) so often.

           

          Any suggestions is appreciated.

           

          Thanks and Regards

          Veena

           

           


            • Re: RAM usage high after upgrade QVS 11.2 SR4 / 5
              Felipe Carrera

              Hi Veena

              unfortunately no solution yet. We will check with QlikTech directly what the Problem is, but for sure it is an issue of the release. I update when i have the solution

              best

              felipe

              • Re: RAM usage high after upgrade QVS 11.2 SR4 / 5
                Felipe Carrera

                Hi Veena

                we did not resolve the Problem yet, but found something interesting.

                 

                We tested a big document 8 Gb  in differente Environments, using always the same steps, i.e., opening document, clicking on tab, selecting Chart, doing filter ,.. etc. and took note of RAM usage. Everytime was the QVS restartet

                Basic info

                QV Environment (web Server virtual machine on DMZ / QVS on physical machine in Intranet)

                all users log as custom users (no use of AD)

                QVS RAM = 128 GB

                QV document Size = 8 GB. When document is open the RAM usage is 14 to  15 Gb

                 

                we tested on:

                1. Access Point intern (Intranet) as custom user Ajax and plugIn

                2. Access Point extern (Extranet) as custom user Ajax (plugin did not work for users via Internet, Tunneling Problem)

                3. QV Desktop, working remote on the Server directly

                4. Access Point from extern via VPN plugin

                 

                Results were:

                1. for Ajax (intern and extern), we open the document and tried to open some Charts and the browser showed a "lost Connection" to Server message. The RAM usage went in seconds from the normal Level (58.5GB) to over Maximum working set Limit (120 GB), and then become stable at 65 GB. Doing the same with other Chart happened the same and then the document was not responsive (it hanged) and needed to Close. Extern and intern we got the same behaviour . Using QV 11 SR2 this was not the behaviour with the same Settings and IT architecture.

                 

                2. for plugin (Intranet) the behaviour of the RAM  was as expected

                3. for the qv Desktop, the behaviour of the RAM was as expected

                4. Using vpn, the behaviour was as expected for the plugin

                 

                Conclusion:

                 

                The Ajax Client causes the high Level of RAM consumption. Other smaller documents have the same Problem, but as they are small, there is still enough Memory. RAM usage does not reach the max working set limit

                 

                PlugIn works well, unfortunately and because of our Tunneling Problem, it is not working for external users that  Access over Internet and https

                 

                We do not know why is this Happening.  

              • Re: RAM usage high after upgrade QVS 11.2 SR4 / 5
                Jerry Somsen

                We are planning to upgrade to 11.2 SR5 but your problems have me concerned.   We are a Plugin user, so I just want to verify that you are not seeing many issues with the Plugin Client.   Thanks!  JS

                • Re: RAM usage high after upgrade QVS 11.2 SR4 / 5
                  Michael Taylor

                  HI, this also concerns me as we are due to install qv sr5 on our new server next week, and migrating from our old server. Currently on sr3.

                   

                  we use ajax rather than installing the plugin on users desktops.

                   

                  sounds like a good idea to hold off sr5 for now.. How was sr4?

                  • Re: RAM usage high after upgrade QVS 11.2 SR4 / 5
                    Felipe Carrera

                    We have solved this issue with Qliktech help.  We reviewed the Installation of QV 11.2 SR5 and all Clients plug in, Ajax , Desktop Client, were working as expected. No RAM highs

                    QlikTech tested a sample application (approx 1.5 GB) in different QV Versions and RAM and CPU behaved similar

                    RAM consumption is following a normal trend, based on a facto 6 to 8 (QVW doc size vs RAM Usage)

                     

                    Felipe

                    • Re: RAM usage high after upgrade QVS 11.2 SR4 / 5
                      Felipe Carrera

                      Hi

                      after the QV 11.2 SR4 / SR5 Installation (we did both Upgrades within three weeks, Nov - Dez 2013), we observed several issues, but the most important was the Performance with the Ajax Client for internal and external users.

                      As said, we have a Qlikview Server and a Web Server IIS on a DMZ, external communication over https

                      RAM behaved with the Ajax Client as showed in the figure attached. When doing a test operation, the RAM Usage went from 58.6 GB to 119 GB in 10 seconds to go down to 65.8 GB in the next 10 seconds. I did the same on the QV Desktop Server and saw a normal behavior, RAM Usage went from 58.6 to 73.1 GB in 20 Seconds

                      The apparent problem was the Ajax Client not working correctly  (the plugin was not working, so i could not test it, but theoretically it shall be better, since it connects directly to the QVServer).

                      Main issues found in our System by the Qliktech Consultant:

                      - No ISAPI.dll in 11.2 SR5 (for SR4 we installed the ISAPI Filter manually) >>> lead to the main Problem of the installation

                      - No Traffic in ports 4747 and 4774 for external users, but traffic over 4747 for internal users (Intranet) >> No Tunnel

                       

                      The solution was to reinstall the web Server and set the Features again, because there was the suspicion that the Installation file (msi) was wrong and that is why the Isapi filter was not automatically installed by qlikview during the Installation process.


                      After reinstalling, we did not see the RAM Usage behavior again and the tunelling was working fine (PlugIn), what confirmed that the Installation file was not the correct one. However I see that the Memory usage stucks always at 96 GB what was not the behavior before (it was 70-75GB), and decided to buy more RAM, other solution is to restart the QVS on Weekends and free Memory. Unfortunately i cannot objectively compare individual applications or objects, since we have no test System.

                      hope this helps

                      felipe

                       

                      PerformanceCPU.png