0 Replies Latest reply: Jan 10, 2014 6:03 AM by James Edgson RSS

    QVS 11.2sr5 and IIS7

      Apologies in advance if this post is in the wrong category.

       

      We had and external facing server with QVS 8.5 installed using IIS7 as the web server to authenticate users.  This is rarely used hence the reason it was not upgraded to a newer version.

       

      Now that it is going to be used a lot more and we want to publish an updated qvw using functionality that was not available in 8.5 we have attempted to install QVS11.2sr5.

       

      To do this we completely removed QVS 8.5 and all of the virtual directories from the web site.

      We then installed QVS11.2 selecting to install on a single machine using IIS.  When prompted to select the web site we selected the one that was already created and previously used by 8.5.

       

      The installation seemed to go fine and we have the license key installed correctly and all document CALS assigned to the sole QVW on the server and specific users have been added.

       

      In IIS

      - we are using windows authentication to authenticate users against local users (the machine is not on a domain) and have enabled ASP .net impersonation using authenticated user.

      - We have set a http redirect which points to https://www.mysite.co.uk/QvPlugin/opendoc.htm?document=MyDoc.qvw

       

      The issue I am having is after I have been authenticated by IIS I get the following message "qvp://www.mysite.co.uk/MyDoc.qvw failed to open".  This only happens when I am logged onto my local machine with a username that does not exist on the server hosting QVS

       

      If I try the same thing when I am logged onto a machine on the network that has a username that is the same as a local username of the server hosting QVS but I use alternative credentials when prompted by the browser, then I authenticate against IIS correctly however my local username seems to be getting passed to QVS instead of the username I authenticated with

       

      I will try and explain a little more with an examples.

      On remote server hosting QVS

      Users

           TestUser1

           TestUser2

       

      Domain users

           TestUser2

           TestUser3

       

      Scenario 1 above:

           Log on to local machine with TestUser3

           Go to site in Browser https://www.mysite.co.uk

           Prompted for user name and password - TestUser1

           Browser redirects to https://www.mysite.co.uk/QvPlugin/opendoc.htm?document=MyDoc.qvw

           error message received

       

      Scenario 2

           Log on to local machine with TestUser2

           Go to site in Browser https://www.mysite.co.uk

           Prompted for user name and password - TestUser1

           Browser redirects to https://www.mysite.co.uk/QvPlugin/opendoc.htm?document=MyDoc.qvw

           Document opened, but is logged in as TestUser2

       

      is anyone able to provide some guidance on how IIS7 needs be configured to allow the authenticated user credential to be passed to QVS and in turn the QVW?

       

      I understand that there is a lot more config that I have not detailed so if anyone can help and requires any additional details I can provide it.

       

      Thanks in advance

      Jay