10 Replies Latest reply: Oct 28, 2014 5:43 PM by Edgar Vazquez RSS

    CallEDXFromAjax extension problems

    Sandro Krumbein

      Hello!


      We are trying to use the CallEDXFromAjax extension from Stefan Walther in cooperation with the respective webservice.


      The extension is installed, the webservice is configured (as far as we could) and we are now trying to get the sample app to work. This is where we are stuck:


      Environment: Windows Server 2012, QVS SBE 11.2 SR2, IIS 7.5


      For installing the webservice we have:

      - put the EDX_Wrapper directory into the C:\ProgramData\QlikTech\WebServer directory

      - created a virtual directory under the QvAjaxZfc site in IIS (we have tried the QlikView site as well)

      - converted that virtual directory to an app

      - assigned an application pool to that app (we tried DefaultAppPool and QlikView IIS)

      - put the username and password under which the server runs into the web.config file

      - added the QVS user to the "QlikView Management API" and "QlikView EDX" group

      - restarted the QlikViewDistributionService, QlikViewDirectoryServiceConnector and QlikViewManagementService services


      Configuration of the extension in the app:

      Webservice URL: http://servername/QvAjaxZfc/EDXWrapper/QlikViewTasks.asmx

      Task Name: CallEDXFromAjax_QvApp_v1.0.qvw (we have put it into the root of the primarily mounted folder)

      Task Password: 1234

      No variable names or values


      QlikViewServer configuration:

      For CallEDXFromAjax_QvApp_v1.0.qvw application

      Reload: On external event, Password as above


      What works:

      http://servername/QvAjaxZfc/EDXWrapper/QlikViewTasks.asmx shows the result page according to the extensions documentation

      (http://qvextcalledxfromajax.codeplex.com/wikipage?title=Installation&referringTitle=Documentation)


      What doesn't work:

      Reloading from the sample app. Current error:

      EDX task could not be started... (No distribution service found)

       

      According to our research this error is encountered in the webservice in the QlikViewTasks.asmx.cs file, when the DistributionService is retrieved, but then seems to be null.

       

      QlikViewTasks.asmx.cs:

      // get the default distribution service

      ServiceInfo qvsService = apiClient.GetServices(ServiceTypes.QlikViewDistributionService).FirstOrDefault();

      if (qvsService != null) {

      ...

       

      Can anyone enlighten us as to how this can be resolved or where the problems stems from?

       

      Regards,

      Sandro

        • Re: CallEDXFromAjax extension problems
          Petra Bloem

          Hi Sandro,

           

          What kind of license do you have for your QlikView server? The distribution service is only available with an enterprise license. Not for the small and medium business edition license. The distribution service is also not available on a test server.

           

          regards,

          Petra Bloem

            • Re: CallEDXFromAjax extension problems
              Sandro Krumbein

              Hello Petra!

               

              Thank you for the answer. Where can we find such information? All "differences between server versions" we have found so far have been way more superficial and led to some frustrating development attempts like this one.

               

              And also: is there any way to accomplish the on-demand document loading by button press of the user, that we are after, with the Small Business Edition? I know that we had it working with the EDX commandline tool from Using EDX in QlikView 11
              But only from the commandline on the Server machine itself. Does that work differently?

               

              Thank you!

               

              Regards,

              Sandro

            • Re: CallEDXFromAjax extension problems
              Kelly Bazilio

              Is it works using Qlikview Web Server?

              • Re: CallEDXFromAjax extension problems
                Sandro Krumbein

                I have gained new insights on this:

                 

                I noticed, that in this article Using EDX in QlikView 11 it is mentioned, that to obtain a QlikView Distribution Service instance higher privileges than the "QlikView EDX" group are necessary. So my current theorie is, that it's not that the Distribution Service isn't there, it's just that the Webservice isn't allowed to find it. The source code of the Webservice tells me, that it is only looking for it to then use its ID for the TriggerEDXTask call. As is also mentioned in above article, if there only is one instance we can also use an empty Guid.

                 

                I have tried the commandline tool from QMSEDX Enhanced and it works. Underneath I basically found the same QlikView Management Service calls, but it simply hands over the default GUID. That tells me that it is NOT a missing Distribution Service in itself...

                 

                Solution 1 might be to recompile the Webservice code and take out the search for the QlikView Distribution Service.

                 

                Questions:

                1. Do any of you have experience with configuring the webservice to allow for proper authorization? We have activated ASP.NET Impersonation on the webservice application to switch to an QlikView Administrator and created an additional Application pool, which is configured to run in classical pipeline mode. If only ASP.NET Impersonation is activated for authentication, we get a 401 Error (unauthorized). If we also switch on the Windows-Authentication we get the "No distribution service found" error message, which should be explained by the above privilege problem. Are we missing something here?

                 

                2. In "However, higher-level privileges than membership in “QlikView EDX” are required to get a QDS ID."
                Does higher-level privileges mean, that "QlikView Management API" group privileges are higher than "QlikView Administrators" group privileges? Quite frankly, we haven't tried that lately. Maybe in the beginning, but then other things have been off. The user, which is currently impersonated simply is a QlikView Administrator

                 

                Thank you!

                 

                Sandro

                • Re: CallEDXFromAjax extension problems
                  Edgar Vazquez

                  I have the same problem "No distribution service found" could you solve it??

                   

                  Thanks