11 Replies Latest reply: Mar 9, 2014 2:09 PM by Steve Dark RSS

    Reload Failed

    Vamshi Tataipelli

      Hi I am getting this information, whenever a job is getting failed and even if i run the job manually, the task is getting failed. Can anyone help me?

       

       

       

      (2014-03-09 10:50:28) Information: Executing ClusterID=1, QDSID=e0e82398-386b-b243-f85b-31d0e351431b QDSMain.DistributeTask

      (2014-03-09 10:50:28) Information: Starting task "DEV_COM_HumanSystems_DATA_EXTRACTOR" (Attempt 1 of 1)

      (2014-03-09 10:50:28) Information: Max run time: 1.00:00:00

      (2014-03-09 10:50:28) Information: Document is marked for refresh; Initializing Reload.

      (2014-03-09 10:50:28) Information: Opening "C:\QVDOCS\DEV\SOURCE\COM856873\Data Extraction\HumanSystems\HumanSystems.qvw"

      (2014-03-09 10:50:28) Information: Allocating QlikView Engine

      (2014-03-09 10:50:28) Information: Allocating new QlikView Engine. Current usagecount=1 of 4

      (2014-03-09 10:50:28) Information: An instance of the QlikView Engine is being created

      (2014-03-09 10:50:28) Information: Starting QlikView Engine

      (2014-03-09 10:50:29) Information: Allocated QlikView Engine successfully. Current usagecount=1 of 4, Ticket=1

      (2014-03-09 10:50:29) Information: Loading document "C:\QVDOCS\DEV\SOURCE\COM856873\Data Extraction\HumanSystems\HumanSystems.qvw" (0.15 Mb)

      (2014-03-09 10:50:29) Information: Physical FileSize=0.15 Mb. Memory Allocation Delta for this file=2.57 Mb. Available Physical Memory Before Open=71381.41 Mb. Available Physical Memory After Open=71376.02 Mb. Total Physical Memory=73717.74 Mb.

      (2014-03-09 10:50:29) Information: The document was loaded successfully.

      (2014-03-09 10:50:29) Information: Initializing Checkout (0), Loading document (765), Initializing load (780), Checking read (780), Creating QlikView Engine (780), Checking Size (811), Load (811), Load Completed (843), Tables read (889), Opened successfully (921)

      (2014-03-09 10:50:29) Information: Document was opened successfully

      (2014-03-09 10:50:29) Information: Opened successfully (0)

      (2014-03-09 10:50:29) Information: Starting reload

      (2014-03-09 10:50:29) Information: QlikView->Settings->Document Preferences->Generate Logfile in document is set. Enabling Log Copier.

      (2014-03-09 10:50:29) Information: Waiting for the document log "C:\QVDOCS\DEV\SOURCE\COM856873\Data Extraction\HumanSystems\HumanSystems.qvw" to become available..

      (2014-03-09 10:50:29) Information: The Source Document is being reloaded. DocumentPath=C:\QVDOCS\DEV\SOURCE\COM856873\Data Extraction\HumanSystems\HumanSystems.qvw

      (2014-03-09 10:50:29) Information: Found a document log. FileName=C:\QVDOCS\DEV\SOURCE\COM856873\Data Extraction\HumanSystems\HumanSystems.qvw.2014_03_09_10_50_29.log

      (2014-03-09 10:50:29) Information: Writing documentLog to C:\ProgramData\QlikTech\DistributionService\1\Log\20140309\105028 - DEV_COM_HumanSystems_DATA_EXTRACTOR\DocumentLog.txt

      (2014-03-09 10:50:30) Information: Reloading.

      (2014-03-09 10:50:31) Information: Reloading..

      (2014-03-09 10:50:32) Information: Reloading...

      (2014-03-09 10:50:33) Information: Reloading....

      (2014-03-09 10:50:34) Information: Reloading.....

      (2014-03-09 10:50:35) Information: Reloading......

      (2014-03-09 10:50:36) Information: Reloading.......

      (2014-03-09 10:50:37) Information: Reloading........

      (2014-03-09 10:50:38) Information: Reloading.........

      (2014-03-09 10:50:39) Information: Reloading..........

      (2014-03-09 10:50:40) Information: Slowing down logging. LoggingSeconds=2

      (2014-03-09 10:50:40) Information: Reloading

      (2014-03-09 10:50:42) Information: Reloading.

      (2014-03-09 10:50:44) Information: Reloading..

      (2014-03-09 10:50:46) Information: Reloading...

      (2014-03-09 10:50:48) Information: The Source Document reload complete. DocumentPath=C:\QVDOCS\DEV\SOURCE\COM856873\Data Extraction\HumanSystems\HumanSystems.qvw

      (2014-03-09 10:50:48) Information: Memory Allocation Delta for this file=1.10 Mb. Available Physical Memory Before Reload=71368.99 Mb. Available Physical Memory After Reload=71324.43 Mb. Total Physical Memory=71324.43 Mb.

      (2014-03-09 10:50:48) Error: The Source Document was NOT reloaded successfully. DocumentPath=C:\QVDOCS\DEV\SOURCE\COM856873\Data Extraction\HumanSystems\HumanSystems.qvw.

      (2014-03-09 10:50:48) Information: Initializing Reload (0), Finished (19219)

      (2014-03-09 10:50:48) Error: Reload failed.

      (2014-03-09 10:50:48) Information: Closing the document.

      (2014-03-09 10:50:48) Information: Closed the QlikView Engine successfully. ProcessID=7964

      (2014-03-09 10:50:48) Information: Initializing (0), Finished (266)

      (2014-03-09 10:50:48) Error: Reload failed. Distribution skipped.

      (2014-03-09 10:50:48) Error: The task "DEV_COM_HumanSystems_DATA_EXTRACTOR" failed. ErrorCount=3

      (2014-03-09 10:50:48) Information: Sending Alert Mail to 2 recipients.

       

      I have tried restarting the qlikview server component, distribution component and under status>services, all the services are running. Don't know how to resolve the issue.

        • Re: Reload Failed
          Colin Albert

          You will need to enable Generate Logfile on the documents settings of your QVW, and view the log file to see the cause of the reload error.

           

          How to generate Log files in QV

          • Re: Reload Failed
            Anand Chouhan

            Hi,

             

            Check your log file and in line the reload is failed also manually stop all qlikview services and restart again this then please reload and check reload status.

             

            Hope this helps

            Thanks & Regards

            • Re: Reload Failed
              Steve Dark

              As colin_albert has said the best bet is to get the log file out of QlikView and post that here.

               

              However, given the failure is almost instant when it gets to reloading the document that fails the log file may not get created.  Things that can cause near instant failures are the file missing (eg. it has been renamed or deleted since the reload task was created) or that there is Section Access on the document and the service account that is running the reload can not open the file.

               

              Both of these things should send a sensible error message to the Server log file - but it is worth checking.

               

              If the reload works okay on the Desktop but not the server, check you are not using mapped drives (eg. Q:\) as these will only be known on the desktop, go for UNC paths when possible (eg. \\servername\share\ ).

               

              Hope that helps.

              Steve