13 Replies Latest reply: May 6, 2014 3:46 AM by Peter Cammaert RSS

    QVD Refresh issue!!

      After QVW and QVD are deployed into server, When we refresh the new data few columns value does not appear but using this same new QVD in new QVW it works fine it populates all the values. Why is it creating problem ? because of which i have to re develop my whole project and deploy it again.

       

      Is it every month i have to do this exercise ?

        • Re: QVD Refresh issue!!
          vikas mahajan

          Hii,

          You need to check where qvd's are actually  stored in your applications whether it is generating properly ?

          Make best practice to have a folder structure

           

          Sr NoFolder NameDescription of Folder (Contents)
          1ExtratorAll Scripts to get data from data source and make qvds ( QVD GEN)
          2QvDsAll applications qvd's will be stored inthis folder
          3Excels and Other Support FilesAll Excels Files and supporting files required for applications will be stored inthis folder
          4Media and ImagesAll Images , Logos , Media Files will be stored into this folder
          5Working FolderCurrent Development qvw's will be copied here inthis folder
          6Final ReportsAll Finilised Qvw's Will be copied here and mapped to Access Points of Qlikview
          7Connection StringsAll Connections Strings will be copied with starting Application Name_Connectionstring
          8Mail DistributionHere We will store all qvw's files which we will be scheduling in publisher

           

          All Qvw's please check folder path and make sure that the paths are proper.

           

          Hope this help you.

           

          Vikas

            • Re: QVD Refresh issue!!

              Hi Vikas,

               

              Thanks for replying!!

               

              Yes i do follow proper folder structure. QVD generation is successful.

               

              The problem is it creates the QVD and is also fetches all the columns. But for few column values are not populating.

               

              For EG:

              Old QVD : Country (Column Name)-  India, Singapore , Australia

              New QVD : Country (Column Name) - India , Australia ( It does not populate Singapore)

               

              But the New QVD if i link it with new QVW it works fine, It does not work with Older QVW

            • Re: QVD Refresh issue!!
              Anand Chouhan

              When creating the QVD use NoOfFields() function to check how many fields are fetch for cross check may be some where due to any logic or join it is not seen use it like

               

              LET vNoofFields = NoOfFields('TableName')

                • Re: QVD Refresh issue!!

                  Hi Anand,

                   

                  Thanks for replying!!

                   

                  All the columns are populated:

                   

                  The problem is it creates the QVD and is also fetches all the columns. But for few column values are not populating.

                   

                  For EG:

                  Old QVD : Country (Column Name)-  India, Singapore , Australia ( Values)

                  New QVD : Country (Column Name) - India , Australia ( It does not populate Singapore)

                   

                  But the New QVD if i link it with new QVW it works fine, It does not work with Older QVW

                • Re: QVD Refresh issue!!
                  Peter Cammaert

                  Data Reduction thru Section Access?