0 Replies Latest reply: Jun 4, 2014 8:25 AM by phillip colbert RSS

    Section Access

    phillip colbert

      Afternoon all,

      i'm having some Section Access problems

       

      Once uploaded to the server i can see the App, but a user with Section Access set to USER (via the QMC _>User Tab->Section Access Management) cant.

       

      hidden Script in App:

       

      ACCESS_TABLE:

      LOAD * INLINE

      [

        NTNAME,    ACCESS

        DOMAIN\USERID, ADMIN

        DOMAIN\USERID, ADMIN

        DOMAIN\USERID, ADMIN

      ];

      (where USERID is the users actual ID)

       

      //  Begin Section Access

      Concatenate (ACCESS_TABLE)

      LOAD NTNAME , ACCESS

      FROM [http://MyQVServer/QMS/AuthTable] (html, utf8, embedded labels, table is MySectionAccessTableName);

       

      Section Access;

      LOAD * Resident ACCESS_TABLE;

      Section Application;

      DROP Table ACCESS_TABLE;

      // End Hidden Script in APP

       

      i've made the changes in the Opening tab of Document properties in the APP:

       

      TICK Initial Data Reduction Based on Section Access

      TICK Stick Exclusion

      TICK Prohibit Binary Load

       

      The column headers in my Section Access table in the QMC obviusly match that of the code int he hidden script in my APP:

       

      NTNAME

      ACCESS

       

      i know im doing something daft and silly - anyone got any ideas as i'd be very grateful!

       

      thanks in advance