9 Replies Latest reply: Jul 2, 2014 8:01 AM by Bill Britt RSS

    Session lost

    Ali Azizi

      Hello everyone

       

      We are using QlikView Release 11.00.11282.0409.10 on a single server (Windows 2008 R2). It happens often that users on Monday get the error message "session lost" when they try to access their QlikView apps.

      I have investigated all logfiles on the server (session, event and performance), but I'm not sure what I should look for? But cannot see anything that could be related to this error!?

       

      Usually and as a workaround we reboot the whole server and it helps everytime! Does anyone know about this issue, a better workaround (maybe just restarting the QlikView services...), or any proactive action to prevent this incident?

       

      Best regards

        • Re: Session lost
          Ashfaq Mohammed

          Hi,

           

          Try by selecting server perform refresh automatically without client action from Document properties of your application.

           

          Look at the attached image.

           

          Regards

          ASHFAQ

          • Re: Session lost
            Sunil Chauhan

            try to check weither you plug in is same as qlikview version.

              • Re: Session lost
                Ali Azizi

                The QlikView version is: 11.00.11282.0. The end users use different AJAX:

                 

                ·         Ajax QvWS 11.0.11282.0 SR1 browser.chrome

                 

                 

                ·         Ajax QvWS 11.0.11282.0 SR1

                 

                 

                ·         Ajax QvWS 11.0.11282.0 SR1 browser.gecko 21

                 

                 

                ·         Ajax QvWS 11.0.11282.0 SR1 browser.MSIE 7.0

                 

                ·         Ajax QvWS 11.0.11282.0 SR1 browser.MSIE 8.0

                 

                ·         Ajax QvWS 11.0.11282.0 SR1 browser.MSIE 9.0

                 

                ·         Ajax QvWS 11.0.11282.0 SR1 browser.MSIE 10.

                and very rarely: Windows Exe.

              • Re: Session lost
                Fernando Keuroglian

                Hi , you can change and set the session timeout for each document

                 

                in the QMC, go to document tab, and then the PERFORMANCE tab , then set the max timeout in seconds

                 

                good luck!

                 

                Fernando

                 

                see this QlikView Session lost

                 

                good luck

                 

                Fernando

                • Re: Session lost
                  Ronnie Taborn

                  Is it a particular QVW? What does the events logs say when the issue occurs. If you have a virtual memory error or Inconsistency errors then it is most likely memory.

                    • Re: Session lost
                      Ali Azizi

                      In the Event log I very often see the following error message:

                       

                       

                      1.    Restart: Server aborted trying to recover by restart. Reason for restart: Internal inconsistency, type D, detected.

                       

                      2.    Extensions: Failed to load extension. Make sure it is available at the correct location

                       

                      The error no. 2 is not related to only one QVW but several apps.

                        • Re: Session lost
                          Ashfaq Mohammed

                          Hi,

                           

                          1) you might be running out short of ram.

                          2) Can you confirm you still have extension in the respective path on qlikview server.

                           

                          Do you have 32 bit environment or 64 bit?


                          Regards

                          ASHFAQ

                          • Re: Re: Session lost
                            Bill Britt

                            Hi,

                             

                            The lost session I bet is being cause by the server restart. There is an issue with a document

                             

                            1.    Restart: Server aborted trying to recover by restart. Reason for restart: Internal inconsistency, type D, detected. This is when Qlik gets a general exception on deletion of a dynamic array. Normal fixed by upgrading.

                             

                            2.    Extensions: Failed to load extension. Make sure it is available at the correct location  There was a bug in the older version that has been corrected.

                             

                            11.11282 Is a very old version of the software. You need to look at upgrading.

                             

                            Bill