2 Replies Latest reply: Jan 19, 2015 3:48 PM by Bill Britt RSS

    Change Access Point session timeout with custom authentication?

    David Alcobero Pinyot

      Hi,

       

      I'm using a custom authentication in our web forms authentication login, so in that place we authenticate the user to QV (and IIS)

       

      ....  

      IUser u = new NamedUser(user, null, true);

          try {

              QlikView.AccessPoint.User.GenericAuthentication(context,u);

          }

          catch (Exception e2)

          {

              Response.StatusCode = 500; // SERVER ERROR

              Response.End();

          }

       

      So we generate 2 cookies, one for the IIS (.CorporateCookie) and another one using QlikView.AccesPoint.User.GenericAuthentication for the QV (AccessPointSession).

       

      It works, OK, but.. what about the session tiemout for the AccessPointSession???

       

      I tried to change the settings in the QMC --> System | Setup | Performance

      • Maximum Inactive Session timeout
      • Possible Session timeout

      After changing the timeout in QMC (setup | performance) I can see how it reconnects passed the time timeout time, but it's not the AccessPointSession! So it just reconnects to QV, it's not about the session in the A.P.

       

      Also in the document  tab, but I think its about the time the document is cached in the memory..

       

      I also change the IIS timeout (in the default website and in the webforms authentication cookie), but the problem is not in the IIS side, because the auth. cookie (the corporate one) is still alive, so I'm pretty sure the problem is in the AccessPointSession cookie.

       

      As I could observe, the A.P session timeout value is between 30 - 40min and is too low for our customer requeriments.

       

      I have no control about how QlikView.AccessPoint.User.GenericAuthentication generates the cookie, so.. any idea how to change the expiration time?

       

       

      I will apreciate any clue!

       

       

      Thanks!