0 Replies Latest reply: Sep 17, 2014 5:28 AM by Nathalie GILETTI RSS

    Erreur aléatoire lors de l'appel du connecteur GA de QVSource via Qlikview

      Bonjour,

       

      J'ai développé un document Qlikview qui lance automatiquement une succession de requêtes GA QVSource en fonction d'un fichier de configuration afin de rapatrier les données GA quotidiennement.

       

      Ce document Qlikview fonctionne très bien SAUF:

           - de façon aléatoire les données en retour de QVSource sont vides et me génère une erreur de type:

      Error: File extdata.cpp, Line 2894

      NoConcatenate

        QvSourceTable:

        load

        *

         from

        [http://localhost:5555/QVSource/GoogleAnalyticsConnectorV3/?table=DataFromQueryURI&appID=&feed=https%3A%2F%2Fwww%2Egoogleapis%2Ecom%2Fanalytics%2Fv3%2Fdata%2Fga%3Fids%3Dga%26xxxxxxx%26dimensions%3Dxxx%26metrics%3Dxxxxxx%26filters%3Dxxxx%26start%2Ddate%3D2012%2D12%2D17%26end%2Ddate%3D2012%2D12%2D17%26max%2Dresults%3D10000] (qvx)

       

       

      La problématique n'est pas la syntaxe de ma requête QVSource car si je la lance avec le requêteur QVSource, elle fonctionne.

      Le problème est que sur 100 appels par exemple, certaines requêtes vont tomber en échec.

      Si je relance le même traitement, celui-ci peut fonctionner tout comme planter sur des appels différents de la première fois.

      L'inconvénient majeur est que mon traitement automatisé tombe en erreur au lieu de passer à l'appel QVSource suivant.

       

      Initialement, je récupérais explicitement toutes les colonnes en sortie de mon appel QVSOURCE.

      J'ai donc préféré faire un " load * from marequete" et en fonction du nb d'éléments en retour je charge mes données.

       

      Il me reste l'option de faire un len(marequete) avant mon load (par contre cela coute 2 appels QVSource !..) mais dans tous les cas mon problème à résoudre est:

      Pourquoi QVSource ne répond pas à 100% des requêtes qui lui sont soumis?

       

      Merci pour votre aide