1 Reply Latest reply: Dec 5, 2014 6:15 AM by Pablo Labbe RSS

    QlikView Distribution Problem - QVB.exe / Reload task hangs... sometimes

    Klaus Feldam

      Environment Information:

      • Product name QMS Backend Core x64
      • QlikView 11 SR7 (11.20.12451.0)
      • Publisher License Key No License
      • Service authentication AD groups
      • Operating System Version Win32_OperatingSystem=@ X64 (Microsoft Windows NT 6.1.7601 Service Pack 1)
      • .NET Version 4.0.30319.18444
      • Physical Memory 31249Mb
      • Available Memory 20187Mb
      • 4 x CPU Intel(R) Xeon(R) CPU E5-2670 v2 @ 2.50GHz

       

      ----

       

      For the past 7 weeks we have experienced problems with the QlikView Distribution Service on our QlikView Server (QlikView 11 SR7 on server and clients)

       

      The problems have been with two of our QVW reloads, where the Distribution Service would cause the two reloads to hang at least 4 times every day. To recover from this situations, we are forced to kill the hung QVB.exe processes, delete any TMP files and re-run the reloads.

       

      We have been troubleshooting this issue for weeks, but have been unable to get to the root cause.

       

      Observations:

      1) The problems are only occurring with 2 out of 32 QVW reload tasks.

      2) The 2 QVWs experiencing the problem has a reload scheduled every 20 minutes / 3 per hour / 72 per day. The hung process only happens approx. 4 times out of the 72 times the reload task is running.

      3) When the QVB process hangs, it happens at specific times during the day (every 3 hours). Although the QVB process doesn't hang every 3 hours, it always happens at either 12am, 3am, 6am, 9am, 12pm, 3pm, 6pm

      4) Manual reloads of data from the QlikView client are always successful. Reload time: 3 minutes

      5) The 2 affected QVWs queries both SQL tables and QVDs.

       

      6) If we remove the QVD queries and access only SQL tables, the reload tasks hang EVERY time.

      7) When the hangs are happening, no error messages are occurring, which means that no errors are captured in the Distribution log, QlikView logs or Windows Logs.

      8) Since no errors are logged and no crashes are taking place, Windows Debugger isn't logging anything either.

       

      Qlik Support has shown little interest in helping and I have spent hours providing log files without any feedback on possible root causes.

       

      Any ideas of what we should do as next steps, other than a complete re-installation of QlikView 11 SR7?