3 Replies Latest reply: Dec 4, 2014 9:56 AM by Alexander Karlsson RSS

    Why does Proxy Service (QPS) not listen on port 443?

    Paul Scotchford

      According to the Install guide for QlikSense, it states that the QPS will listen on port 443, or am I misinterpreting this?

      I note that QPS is listening on Port 51240 using UDP protocol.

       

      Is this correct, as I am still having issues trying to get QMC to open in a Browser page, basically it cannot display the page.

       

      I am getting frustrated with this as the documentation and general experience in the community is sparse and does not

      address the issue.

       

      Any help / suggestions would be deeply appreciated.

       

      Thanks

       

      Paul

        • Re: Why does Proxy Service (QPS) not listen on port 443?
          Alexander Karlsson

          Hey Paul,

           

          Yes for external communication the QPS listens to port 443 by default.

          What you are observing are most likely the traffic from the QPS to other Qlik Sense services.

           

          Can you open QMC on the machine where QS is installed?

          Make sure there are no firewalls or proxy settings blocking or intercepting any traffic on the server.

          How are you trying to access QMC, through https://<machine name>/qmc/ or some other address?

           

          QS will self-sign certificates when you install it for the current machine name so if you have your own SSL certificate make sure you apply the thumbprint to the proxy otherwise you will get a lot of SSL errors from the clients.

            • Re: Why does Proxy Service (QPS) not listen on port 443?
              Paul Scotchford

              Hey Alexander

              Thanks for replying.

              Unable to open QMC "Cant Display Page" error.

              Proxy is fine, tested that.

              No obvious blocks in the firewall that I can see.

              I'm accessing QMC, through https://<machine name>/qmc/ , which is the same as the QS shortcut icon.

              I have installed QS on a Win Server 2008 R2 Virtual, thinking that this might be an issue I also tested an install on a

              new Physical server running Win 2012

              I'll double check with the infrastructure team again to see if 443 is blocked somewhere else in the forest causing the problem...

               

              Are you running QS server ?

               

              thanks

              Regards

              Paul