19 Replies Latest reply: Dec 1, 2015 7:23 AM by Daiana Rossignol RSS

    Windows 2012 QlikView 11.20.12577.0 AJAX Access Point Slow

    Pet Beles

      Hi

       

      I have noticed there are other discussions around but no solution provided so far:

       

      We have setup a new environment on Windows 2012 Server R2. We used the binary 2012 and up Version 11.20.12577.0.

       

      We are able to execue our main app on the server in the matching fat client => performance is very good

      We are able to use the IE Plugin => Performance is very good

       

      When we do start the same report in the AJAX client the performance is very bad. Every click takes around 1 second. Even if nearly no data is selected. Even if only changing the status of a check box. After a few minute the connection breaks by showing only the "busy" mouse coursor.

       

      Memory and CPU usage is independent of the accessmethod low low:

      Physical RAM(MB)65501
      VMCommitted(MB)971
      VMAllocated(MB)1254
      VMFree(MB)58196
      VMLargestFreeBlock(MB)58196

      CPU Cores: 32 x Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz 1995MHz. CPU utilization when performing queries: about 1%

       

      So far I was assuming that a network problem / proxy / firewall could cause the problem but even if the browser on the server is used to access the AJAX interface the performance is bad and if used with the IE Plugin the performance is good everywhere.

       

      We have checked that the connection is not tunneld via port 80. All relevant ports are open: 4747, 4774, 4720, 4750, 80, 4780, 4799, 4730, 4735. We have also restarted all QlikView Services before testing the performance.

       

      As I have read that other people do have similar problems with Windows 2012 => could this be related to Win 2012, Ist it related to the Qlik SP we are using?

       

      Any ideas are welcome.