2 Replies Latest reply: Jan 9, 2015 3:18 AM by Chris Atkinson RSS

    IE Plugin Load

      Hi there,

       

      We are using QV 11 here and have several dashboards published via the AccessPoint.

       

      We are trying to generate URLs for ease of access to give to users. These follow the format:

       

      http://server/QvAJAXZfc/AccessPoint.aspx?open=&id=localhost%7Cfile.qvw&client=Plugin

       

      This URL is simply copied from the relevant dashboard on the AccessPoint (right click, copy shortcut).

       

      However, we are seeing strange behaviour. When browsing directly to this URL (with IE closed, or with IE open on a page other than the AccessPoint), we get automatically redirected back to the home page of the AccessPoint (http://server/qlikview/index.htm).

       

      If the AccessPoint is open in IE and we use the above URL, it actually opens the dashboard directly - which is the behaviour we are trying to achieve.

       

      My question is: why does the URL redirect to the AccessPoint homepage when IE is not open or on a different page? Ideally we want the end users to use the URL and be presented directly with the dashboard loaded and open in all circumstances.

       

      I've been advised that this is possible (from someone's past experience).

       

      The IE plugin is fully installed and is OK.

       

      Thanks

      Chris

        • Re: IE Plugin Load
          Marcus Sommer

          For this you will need a valid qv-session and it will be require a login or SSO. But even by SSO I'm not sure if it will work in your way that a session will be started and then a redirect goes to your app. But perhaps there are settings for this ... maybe Bill Britt could help.

           

          - Marcus

            • Re: IE Plugin Load

              Thanks Marcus, that does make sense with what I'm seeing - i.e. if the SSO session is setup by navigating to the AccessPoint then the URL works, but otherwise not.

               

              I'm hoping there are settings for this (although I've looked everywhere I can in the QMC). Just basing this on someone that managed a QVS installation in another organisation that said it could be done (not managed in a technical sense so I have no details)?!