6 Replies Latest reply: Jan 13, 2015 4:09 AM by Jose Cardenas RSS

    Updating data in a published document, result: access denied

    Jose Cardenas

      Hi everybody,

       

      I'm working with qlik sense server 1.0 and I've already created and app with its respective data load section.  I was able to publish the application and give it the right access to be used.  However when I've tried to update the data (btw I've accessed a mix of qvd files and sqlserver and xls files.  Everything is working!) using the respective manual task I'm getting failed status.  I've checked the log and its telling me "Document Load: The document XXXXXXXX-yyyy-WWWW-ZZZZ-VVVVVVVVVVVV failed to load because of no access [5]" (I've hide the document id) I'm not sure what does mean the number 5 in the message but it seems to be that its failing trying to save the respective published app in the stream

       

      I've tried given full access (Create Read Update Delete , .... ) to the app and reload task (App_*,ReloadTask_*) in the security rules and not worked at all.  The unique thing I've notice once I gave the app access to owner (Yes! I'm using sense_system in this case), I was able to see the "data load editor" and "data modeller viewer" options (Wasn't enable before the security rules modification). So, I've decided to test if I were able to manually reload the data in the hub opening the published app and click in the load data button, and at the end I've got the "access denied" message. Cool!  (btw Sarcastic! on this point. I'm getting mad!, but I've thought ...  I'm going to find the solution here! )

       

      Long story, Isn't?  But I've tried all possible logical options comparing with the administration cases found on qlikview platform (not many qlik sense information related was founded) but I wasn't able to get the right and expected result successfully for qlik sense!

       

      Please, urgent, I need a clue to get this staff working. I appreciate any help !

       

      Thankfully!

       

      Jose