4 Replies Latest reply: May 12, 2015 9:26 AM by Rudy Welvaert RSS

    Qlikview 11 for developers -Ch 7 script load error

    Hein Frohnapfel

      Hi there,

      Busy with chapter 7 (P220) and having problems to load the script under aircraft tab as indicated below:

      When I load the script in a new .qvw file it loads, my model for chapter 7 fails to load.

      What am I doing wrong?

       

      [Aircraft Types]:

      LOAD AC_TYPEID as [%Aircraft Type ID],

           AC_GROUP as [%Aircraft Group Type],

           SSD_NAME as [Aircraft Name],

           MANUFACTURER as [Aircraft Manufacturer],

           LONG_NAME as [Arcraft Name Full],

           SHORT_NAME as [Aircraft Name Abbreviated],

           BEGIN_DATE as [Aircraft Begin Date],

           END_DATE as [Aircraft End Date]

      FROM

      [..\Data Files\CSVs\Aircraft_Base_File.csv]

      (txt, codepage is 1252, embedded labels, delimiter is ';', msq);

      [Aircraft Groups]:

      LOAD [Aircraft Group ID] as [%Aircraft Group Type],

           [Aircraft Engine Type],

           [Aircraft Number Of Engines]

      FROM

      [..\Data Files\CSVs\Aircraft_Group.csv]

      (txt, codepage is 1252, embedded labels, delimiter is ';', msq);

       

      I should achieve the following results as per handbook

      When commenting out above script and replace with original script my data loads correctly

      [Aircraft Groups]:

      LOAD [%Aircraft Group ID],

           [Aircraft Group]

      FROM

      [..\Data Files\QVDs\Aircraft Groups.qvd]

      (qvd);

       

      [Aircraft Types]:

      LOAD [%Aircraft Type ID],

           [Aircraft Type]

      FROM

      [..\Data Files\QVDs\Aircraft Types.qvd]

      (qvd);