2 Replies Latest reply: Jun 30, 2015 9:02 AM by Bruce Ferman RSS

    Connect Expressor to a Salesforce Sandbox Environment

      A challenge when connecting Expressor to a Salesforce Sandbox Environment is getting the connection type details right.  Here, I'll walk you through configuring the connection details.

       

      Once you've enabled the Salesforce Expressor extension (see here: Tutorial: Using Read Salesforce and Write QlikView Operators - YouTube) and create your Salesforce connection type, you'll be faced with a prompt to enter your Salesforce connection details.

       

      1. Make sure you're using the correct user name.  By default, your Sandbox user name will have a period and the name of the Sandbox appended to the end of your Production environment user name.  So if your Sandbox name is "Dev", then your Sandbox user name will be defaulted to: [production user name].dev
      2. Generate a token if you don't have one and use it.  You'll find the "Reset my security token" link under Setup and inside of the "My Personal Information" menu.  When you "reset your token" you'll get an e-mail with the token value to use in the Salesforce Expressor connection settings.
      3. The correct URL isn't the URL of the Sandbox login page...
        1. To find the proper URL to use, browse to and login to your Salesforce Sandbox environment then enter the Setup menu using the link in the upper right corner of the screen.
        2. Under the Develop menu in the left sidebar, click API then select the Generate Partner WSDL link.
        3. You'll find the URL you need at the bottom of the generated WSDL, just to the right of the line reading: <soap:address location=
        • Re: Connect Expressor to a Salesforce Sandbox Environment
          Ramesh A

          This is useful article. I'm getting following error when I tried to connect to Sandbox using Expressor:

           

          Cannot establish connection, errorCode 1 message: "The response from Salesforce.com has incorrect structure. Please, check internet settings and date settings on your local computer. Code 1"

           

          Please let me know .. did anyone faced issue and solution for the same.

          -Regards

          Ramesh

            • Re: Connect Expressor to a Salesforce Sandbox Environment

              Hi Ramesh, this is the message you'll get for any sort of a connection problem.  The cause can be any missed step from the article.  Try out the URL you're using from the WSDL in your browser, just log into your sandbox and manually enter the URL into your browser's address bar.  If you're not getting back a slew of XML then you may have not copied the URL from the WSDL properly.  If you're using an older version of Expressor you may need to change the API number at the end of the URL to an earlier version.  It's also easy to select the wrong URL from the WSDL, so follow the instructions carefully!

               

              Other causes could be an invalid token or password.  Remember, unlike most other services that connect to Salesforce Expressor does not expect you to prepend your password onto your token, it wants the values separated.

               

              Lastly, Expressor does provide a little help in troubleshooting connection issues with Salesforce.  When you're in the process of configuring the Salesforce connection take note of the Test Connection button in the upper left corner of the user interface.  Pressing that button tries connecting to Salesforce and will hopefully show you a more verbose error giving you the clue you need to better troubleshoot the issue.

               

              Good luck!