5 Replies Latest reply: Apr 8, 2015 9:57 AM by Serhan Celebi RSS

    KML area display on Qlik Sense

      Hi,

      I have loaded the script below:

      LOAD

          CompanyName,

          "Density Per Sq Mile",

          geomakepoint (Lat, Long)

      FROM xxx

       

      LOAD

          map.Name as name,

          map.Point as point,

          map.Area as area

      FROM [lib://IDN US/map.kml]

      (kml, Table is [map/cb_2013_us_cbsa_20m]);

       

      When I drag and drop "area it tells me: the action you are attempting cannot be applied to this visualization.

      Also, when I use GeoAggrGeometry(area) as area it does not let me load since the expression is invalid!

       

      Any Help?

      Thanks,

        • Re: KML area display on Qlik Sense
          Serhan Celebi

          Hello,

           

          When you try "Add Dimension" to the map object you get this error? 

           

          If yes, there should be a problem with the file. Corrupt or something. Try to recreate it.

           

          BR

           

          Serhan

            • Re: KML area display on Qlik Sense

              I guess my file is working fine since I uploaded the KML file on Google map and it worked. Also, when I loaded the KML file, Qlik Sense showed me the tables of data for Area, point, and name. Besides, the file is from US Census.

              So basically, I have an area on my map which shows counties in a KML file. Besides, I have data points in a separate file that I want to show on the same map.

              I did an experiment and first added the are as a layer and it worked fine. After I wanted to add data points with geomake point (lat, long) it gave me the same error.

            • Re: KML area display on Qlik Sense

              Hi Milad,

               

              It may be your version of Qlik Sense? I am using the latest release (1.1.0).

               

              I just found a file with the same name as yours (cb_2013_us_cbsa_20m) and it imported fine and I was able to create a map using the Area data.

               

              I have attached the qvf for reference.

               

              Hope this helps.

               

              Regards,

               

              Rod

                • Re: KML area display on Qlik Sense

                  Thanks Rod,

                   

                  My Qliksense version is 1.1.0

                  I did some more experiments. So I am able to my my are, but I cannot add my geographical points on it. So basically I have 2 sets of data:

                  1. My data points with Long and Lat ( I integrated them by Geomakepoint (Lat, Long) as Geo)

                  2. My KML file that has area on map

                   

                  I want to have both area and data points (1470 points) on the same map.

                  When I first add Area as a layer to map, I can add the points, but it does not show me locations for it. The map remains the same as only showing the area.

                  Besides, when I first add points as dimension. It does not let me to add a layer (Area).

                  What should I do?