2 Replies Latest reply: Apr 30, 2015 6:44 AM by Friedrich Hofmann RSS

    Strange - total malfunction ...

    Friedrich Hofmann


      Hi,

       

      I am facing an issue which leaves me totally clueless:

      => I have an app which contains one subroutine which contains another subroutine

      => That worked fine just yesterday, I tried it out several times

      <=> Today I edited something and now I am facing the issue that
             => in the Debugger, when I go step-wise, before it has even completed both subroutines, the system just stops and the button "close" becomes active - just after the first > end sub <, with the second (outer) subroutine yet to parse (the calling part would of course come afterwards)

       

      Can you make head or tail of this?

       

      Thanks a lot!

      Best regards,

       

      DataNibbler

        • Re: Strange - total malfunction ...
          Friedrich Hofmann

          OK,

           

          I'm in hot pursuit of the bug ;-)

          It seems that, as so often, the error is somewhere inside the subroutine, that causes the whole thing to crash.

          There is one empty table and then I have a RESIDENT LOAD with a FIRST 1 from that table - that of course does not work.

            • Re: Strange - total malfunction ...
              Friedrich Hofmann

              OK,

               

              that seems to have been it.

              It's a bit irritating that, apparently, when there is some error inside a subroutine, that isn't even parsed in the Debugger - before reaching the calling part and executing it - so the script doesn't throw an error, but simply stops.

               

              One has to dactivate the > sub < and > end sub < commands and rearrange things so that it's normal code to execute only once, then you can debug it.

               

              I hope that will help others who face this issue.