7 Replies Latest reply: May 20, 2015 1:56 PM by Dinesh Ponnekanti RSS

    Issue on refreshing a qvw on QMC

    Dinesh Ponnekanti

      I keep getting this message(as shown in the attachment) and the refresh last like forever.

       

       

      Not sure whats the issues is?

      when i reload the same file on local machine it works perfectly fine.

       

      Please advise.

        • Re: Issue on refreshing a qvw on QMC
          Dinesh Ponnekanti

          Need some help on this.

          • Re: Issue on refreshing a qvw on QMC
            Bill Britt

            Hi,

             

            I am not sure this is an issue. What this means is that in the document you have a list box set to "Always one Selected Value". So, for the distribution service to reload all the data it has to uncheck this option. One the reload is finished it will check set it back.

             

            If you are having issue you need to post more of the log.

             

            Bill

              • Re: Issue on refreshing a qvw on QMC
                Dinesh Ponnekanti

                Hello Bill,

                It seems like it but i have so many list boxes where all of them were conditioned to be always one selected value.

                 

                If thats the problem how to get rid of it? can you help?

                anyway here is the full log

                (2015-05-18 23:16:48) Information: Starting task 'Copy of Copy of DEV- Distribute of test.qvw  - CA'. Id:7bb49ad7-1cd6-469e-a928-1d566657289e. Triggered by 'ManualStartTrigger'. Id:00000001-0002-0003-0405-0607080a0b0c

                (2015-05-18 23:16:48) Information: Entering Task Execution.

                (2015-05-18 23:16:48) Information: ClusterID=2

                (2015-05-18 23:16:48) Information: QDSID=26cd85f4-6de9-b759-32de-d345bf754ce9

                (2015-05-18 23:16:48) Information: TaskID=7bb49ad7-1cd6-469e-a928-1d566657289e

                (2015-05-18 23:16:48) Information: MaxRunTime=1.00:00:00

                (2015-05-18 23:16:48) Information: MachineName=WA00973D

                (2015-05-18 23:16:48) Information: Max attempts:1

                (2015-05-18 23:16:48) Information: Current Attempt=0

                (2015-05-18 23:16:48) Information: Task Dependencies are OK

                (2015-05-18 23:16:48) Information: Start document distribution.

                (2015-05-18 23:16:48) Information: Opening source document

                (2015-05-18 23:16:48) Information: Opening document: "test.qvw"

                (2015-05-18 23:16:48) Information: Allocating new QlikView Engine. Current usage count=0 of 24 (of type non-reader).

                (2015-05-18 23:16:48) Information: Max retries:5

                (2015-05-18 23:16:48) Information: Attempt:01

                (2015-05-18 23:16:49) Information: Opened the QlikView Engine successfully. ProcessID=13296

                (2015-05-18 23:16:49) Information: Allocated QlikView Engine successfully. Current usage count=1 of 24 (of type non-reader). Ticket number=12.

                (2015-05-18 23:16:49) Information: Loading document "E:\Qlikview\Test\test.qvw" (241.25 Mb)

                (2015-05-18 23:16:50) Information: Loading. LoadTime=00:00:01.0140000

                (2015-05-18 23:16:52) Information: Loading. LoadTime=00:00:03.0420000

                (2015-05-18 23:16:56) Information: Loading. LoadTime=00:00:07.0980000

                (2015-05-18 23:17:04) Information: Loading. LoadTime=00:00:15.2100000

                (2015-05-18 23:17:08) Information: Physical FileSize=241.25 Mb. Memory Allocation Delta for this file=2057.08 Mb. Available Physical Memory Before Open=179373.00 Mb. Available Physical Memory After Open=177328.32 Mb. Total Physical Memory=196573.28 Mb.

                (2015-05-18 23:17:08) Information: Attempted to load the document with data.

                (2015-05-18 23:17:08) Information: The document was loaded successfully.

                (2015-05-18 23:17:08) Information: Disabling One and always one


                After this message it takes like forever to respond and it never gets completed successfully.

              • Re: Issue on refreshing a qvw on QMC
                Peter Cammaert

                Lots of data with lots of synthetic keys? Do you have a memory spike at the end of the reload?

                • Re: Issue on refreshing a qvw on QMC
                  Dinesh Ponnekanti

                  Not sure whats the issue was but i have created a trigger

                  on post reload->clear all

                  on open-> Clear all

                   

                  Then the refresh task worked fine and successful.

                   

                  But the issue is still happened to be a mystery though.

                   

                  @Bill Britt - I didn't check the document log missed on that probably it would have given much more info on the issue

                   

                  @Peter Cammaert - That's what i have been told by our admin team that there might be a synthetic key but i don't find any on the data model though.

                  • Re: Issue on refreshing a qvw on QMC
                    Dinesh Ponnekanti

                    Is there a possibility that the QVW file can get corrupted when the qlikview engine max out and the app tried to run again and again?

                     

                    Thanks.