1 Reply Latest reply: May 27, 2015 10:53 AM by Allard Couwenberg RSS

    "Field not found" after adding excel data via initial app launcher

      Hi,

       

      I'm currently trying to learn qlik sense desktop. From our database I dumped data to an excel file, added the directory as lib and selected the file as source. After selecting relevant data qlik starts reading in all data from excel sheet. Works fine. Second step I add an other excel using the already set up lib. Again I select the relevant data and add the skript into my data sources. Now I need to reload because this time qlik does NOT read in the data from excel file. Therefore I press "reload data" earning an error from the first excel sheet: "field not found". well, it's def. there... Why does it work the first time and fails the second time with nothing else changed but an additional data source?

       

      Here is my resulting skript:

       

      porder2products:

      LOAD

          PRODUCT_ID,

          PORDER_ID,

          POSITION,

          PRICE,

          RETURN_STATUS_ID

      FROM [lib://Desktop/porder2product_mai.xlsx]

      (ooxml, embedded labels, table is [p2p]);

       

      porder:

      LOAD

          PORDER_ID,

          COMMISSION_ID,

          PARCEL_ID,

          WEIGHT,

          PLC,

          PARCEL_STATUS_ID,

          DISPATCH_TYPE_ID,

          MAIN_PRODUCT_ID,

          TSCREATE,

          STORE_ID,

          TERMINAL_ID,

          TSUPDATE,

          PARCEL_ID_UNIQUE,

          LICENSE_PLATE

      FROM [lib://Desktop/porderparcels_mai.xlsx]

      (ooxml, embedded labels, table is [pp]);