0 Replies Latest reply: Jun 10, 2015 1:01 PM by Patrick Roser RSS

    QMC settings (and license) disappeared after RAM overflow

    Patrick Roser

      Hi there,

       

      yesterday we had an issue with a clients installation.


      First of all, the QlikView Server is not up to date, its version is about 11.0.2xxxx.

       

      During a SQL-select the select stopped. According to Windows Event Log the System went out of system resources. Following I found plenty of these errors in the event log.

       

      After restarting the services I tried to start the reloads, which failed, because the server claimed to be license-less. Although I saw the LEF file, the QMC didn't show the license.
      After reentering the license I tried to start the reload again, which again failed. This time the error was, that the qvw couldnt be found. I had a glance at the user documents and just found the 3 default applications.

       

      I knew, that the QVPR gets backupped each day, therefore I recovered it from the day before yesterday, didn't change anything. So I tried to recover some older backups, with the same results, folder structure wasn't recovered.

       

      Therefore I reconfigured the QMC, after doing this everything worked properly.

       

      So, that's my story, I got a few questions, hoping someone could enlighten me:

       

      • We had the same issue at another clients installation (11.0 IR) about two months ago, does anybody know why running out of memory can result in resetting the QMC?
      • Two months ago, after reconfiguring the QMC, I've been told by the support, that I just could have recover the QVPR backup, which contains all the settings of the QMC. I tried it this time, like mentioned in the knowledge base, but without any results. Anybody knows why? Or didn't I understand it correctly and the QVPR backup isn't capable of restoring the QMC settings?
      • We arranged an update for the server, but the client just asked me, if the update helps avoiding this error in future, or could this also happen with the current releases?
      • The reason why I'm asking the last question is also because of a third client, who also faces issues with the memory. Their version is 11.20 SR6 or 7. They need to restart the services frequently to avoid running out of memory which also already caused other services to be stopped. Therefore I wanted to know if similar issues with memory still exist.

       

      I might have written my issue quite a bit confusing, so please let me know if I can provide further information to clarify my problem.

       

      Thanks in advance

       

      Patrick