3 Replies Latest reply: Jun 19, 2015 10:40 AM by Greg Anderson RSS

    Distribution failed after changing AD LDAP setting in DSC

    Greg Anderson

      Hi, all.

       

      We recently migrated our QlikView servers to a new Active Directory domain.  The migration went well, and we got our licenses reassigned to use LDAP on the new AD without a problem.  I did leave the previous LDAP setting as secondary during the migration to give us time to migrate bookmarks and catch any users we might have missed.

       

      When we had to cut the old AD completely, our Distribution stopped working.  Nothing will publish to the QVS for the Access Point.  It's always the same error:

       

      QDSMain.Exceptions.TaskFailedException: Task execution failed with errors to follow. ---> QDSMain.Exceptions.DistributeToResourcesFailedException: Distribute to resource failed. ---> QDSMain.Exceptions.DscOffLineException: Failed to AddNamedUsers at QDSMain.Support.DSCHelper.AddNamedUsers(ILogBucket logBucket, XmlDocument xml, List`1 namedUsers, FileSystemPluginHelper fileSystemPluginHelper)

         at QDSMain.Support.DSCHelper.GetFileSystemSecurity(ILogBucket logBucket, FileSystemPluginHelper fileSystemPluginHelper, List`1 recipients)

         at QDSMain.QlikViewServerDistributionResource.CreateSettingsBlock(ILogBucket i_LogBucket, FileSystemPluginHelper i_FileSystemPluginHelper, String i_SourceDocumentName, DateTime

       

      These documents distribute to all authenticated users.  I even tried 'All Users', with the same result.

       

      None of our authenticated users are trying to hit the old domain.  We cleared out (or migrated) every bookmark from the old AD users.

       

      I cannot find a single setting or note that references the old AD LDAP, but I'm still getting this message. 

       

      Any input would be greatly appreciated.  Thanks!