0 Replies Latest reply: Jul 1, 2015 5:40 AM by Lucas Nemes RSS

    sybase advantage oledb Error 7200

      Hi everybody,

       

      I'm actually coming across some troubles when I try to connect to my remote Sybase Advantage database server 11.1 via an OLE DB connection.

       

      Previously I connected via OLE DB on remote connection type  to a Sybase Advantage on my local laptop and everything worked fine.

       

      Now I try to connect on the remote master server and nothing work.

       

      Here is my line of connection:

       

      OLEDB CONNECT TO [Provider=Advantage.OLEDB.1;User ID=XXX;Data Source=\\SRVXXX.DOMAINXXX\AppData\BOB50SQLDATA\XXX;Initial Catalog=\\SRVXXX.DOMAINXXX\AppData\BOB50SQLDATA\;Mode=ReadWrite;Extended Properties="";Advantage Character Data Type=ADS_ANSI;Advantage Compression="Internet";Advantage Encryption Password="";Advantage Filter Options=IGNORE_WHEN_COUNTING;Advantage Locking Mode=ADS_COMPATIBLE_LOCKING;Advantage Security Mode=ADS_CHECKRIGHTS;Advantage Server Type=ADS_REMOTE_SERVER | ADS_AIS_SERVER;Increment User Count=FALSE;Show Deleted Records in DBF Tables with Advantage=FALSE;Stored Procedure Connection=FALSE;Advantage Table Type=ADS_ADT;Trim Trailing Spaces=FALSE;Use NULL values in DBF Tables with Advantage=FALSE;Advantage Communication Type="";FIPS=FALSE;EncryptionType="";DDPassword="";TLSCiphers="";TLSCertificate="";TLSCommonName=""] (XPassword is XXXXXXXXXXXXXXXXXXXXXXXXX);
      
      LOAD XXX;
      SQL SELECT XXX
      FROM \\SEVXXX.DOMAINXXX\AppData\BOB50SQLDATA\XXX."ac_accoun";
      

       

      Which QlikVIew answers:

       

      ErrorSource: Advantage OLE DB Provider, ErrorMsg: Error 7200:  AQE Error:  State = 42000;   NativeError = 2117;  [iAnywhere Solutions][Advantage SQL Engine]Unexpected token: . -- Expecting semicolon. -- Location of error in the SQL statement is: 53 (line: 3 column: 24)   SELECT XXX
           FROM \\SRVXXX.DOMAINXXX\AppData\BOB50SQLDATA\XXX."ac_accoun"
      SQL SELECT XXX
           FROM \\SRVXXX.DOMAINXXX\AppData\BOB50SQLDATA\XXX."ac_accoun"
      

       

      I have tried to change the READWRITE option to READ only, compression to NONE even though the server have compression set to "Internet". None of those work.

       

      The server is a remote TS Windows 2012 R2. I can join it via remote desktop and windows explorer. My login and pass are correct.

       

      At this point I have absolutly no idea of any solution.

       

      I've searched on google and found nothing relevant or the proposed solution didn't worked.

       

      So, I hope that some of you could maybe help me.

       

      I thank everybody in advance who will take time to read my problem.

       

      Hope to read you soon. I can explain it in French if you want it.