0 Replies Latest reply: Jul 6, 2015 4:14 AM by Rajesh G RSS

    Getting 0 records while doing Increment load from SAP BW DSO to Qlikview

    Rajesh G

      Hi All,

      I am trying to implement the increment load data(only new records) from SAP BW DSO to Qlikview.To do this I have created one variable with Max date value.

       

      InitialData:
      LOAD [Network_NETWORK./BIC/AZDAT_O2300],
      [Project De_PROJECT./BIC/AZDAT_O2300],
      [Last Chang_CHANGEDATE./BIC/AZDAT_O2300],
      [Created on_CREATEDON./BIC/AZDAT_O2300]
      FROM
      [E:\QLIKVIEW MAIN\SAP BW\SAP BW Transactional Data Transformed QVDs\ InitialData.QVD]
      (
      qvd);

      Last_Update_date:
      LOAD
      max(date([Created on_CREATEDON./BIC/AZDAT_O2300])) as Createdon
      Resident InitialData;
      LET vLast_Created_Date = Peek('Createdon',0,'Last_Update_date');
      drop Table InitialData;

      Till now I do not have any issues.the variable vLast_Created_Date value is = '6/30/2015'

       

      Now I have connected SAP BW DSO and trying to to do new data which are have > vLast_Created_Date,but I am getting Zero records only but we have lot of records in data source. I also checked the date format and make it as same format what we have in source but still i am not sure why I am getting zero records while performing increment load.

       

      Here below is the sample log file .

      7/6/2015 3:49:40 AM: 0105  Incremental:

      7/6/2015 3:49:40 AM: 0107  Load

      7/6/2015 3:49:40 AM: 0110     [NETWORK] as [Network_NETWORK./BIC/AZDAT_O2300],

      7/6/2015 3:49:40 AM: 0111     [PROJECT] as [Project De_PROJECT./BIC/AZDAT_O2300],

      7/6/2015 3:49:40 AM: 0112     [WBS_ELEMT] as [WBS Elemen_WBS_ELEMT./BIC/AZDAT_O2300],

      7/6/2015 3:49:40 AM: 0178   [CHANGEDATE] as [Last Chang_CHANGEDATE./BIC/AZDAT_O2300],

      7/6/2015 3:49:40 AM: 0179    [CREATEDON] as [Created on_CREATEDON./BIC/AZDAT_O2300]

      7/6/2015 3:49:40 AM: 0180  SQL Select  NETWORK PROJECT WBS_ELEMT CREATEDON CHANGEDATE  from IC/AZDAT_O2300

      7/6/2015 3:49:40 AM: 0181  Where CREATEDON > '6/30/2015'

      7/6/2015 3:49:43 AM:      5 fields found: Network Network_NETWORK./BIC/AZDAT_O2300, Project De_PROJECT./BIC/AZDAT_O2300, WBS Elemen_WBS_ELEMT./BIC/AZDAT_O2300,  Last Chang_CHANGEDATE./BIC/AZDAT_O2300, Created on_CREATEDON./BIC/AZDAT_O2300, 0 lines fetched

       

      please provide your valuable suggestions how we can resolve this issue.

      Thanks in advance

       

      Thanks

      Rajesh G