0 Replies Latest reply: Jul 7, 2015 8:33 PM by Sandeep Thool RSS

    Publisher executing .qvw script content only once (first time)

      I have a .qvw script which contains logic to connect to an external database, fetch data & store the data in QVDs. I'm able to successfully configure this .qvw script on publisher & get it to run.

       

      But I noticed the publisher is 'executing' the contents of this .qvw script (i.e. the SQLs) only the first time thereby causing QVDs to get generated only the first time. None of the successive runs are producing any fresh QVDs (hence my QVD timestamps are pretty old, whereas my .qvw script gets constantly updated with a new timestamp, coz it's scheduled on server).

       

      When the .qvw script got executed first time, the publisher logs showed the full script contents (SQLs) in the logs. But during all successive runs the logs do not show any of those script contents (SQLs). The logs simply say 'The Source Document is being reloaded'. And later i see 'Reload finished successfully'.

       

      Clearly it is not actually 'executing' the contents of the script, which is proven by the fact that fresh QVDs are not getting created. I'm not seeing any other errors in any other logs on publisher that'd give me any hints on this issue. Please let me know if anyone faced similar issue.

       

      Environment :

      Qlikview Server: 11.20.12852.0

      OS: Windows 2012 R2 Standard Edition (64 bit)

      .Net Version: 4.0.30319.34014