13 Replies Latest reply: Aug 21, 2015 7:52 AM by Nico Manro Oberholzer RSS

    Qlik Sense Server - User Access Pass

    Nico Manro Oberholzer

      Hi All,

       

      Im new to Qlik Sense Server.

       

      I've installed it onto Win Ser 2008 R2 - VM running of our main company server.

       

      My problem:

      Whever i load the HUB, it does prompt me for a username and password? It immedialtly hits me with the "You have no access pass" error. I cannot provide the login details?

       

      I've tried everything now and its just not working... can someone please help??

      Capture.JPG

       

      Anybody??

       

      Nico

        • Re: Qlik Sense Server - User Access Pass
          Michael Tarallo

          Hi Nico,

           

          Please see this series of videos to help you:

           

          New to Qlik Sense Enterprise Server Videos

           

          specifically: Qlik Sense Platform - Token Licensing and Assigning Access Passes (video)

           

          You need to assign user access before you can continue.

           

          Please mark the appropriate replies as CORRECT / HELPFUL so our team and other members know that your question(s) has been answered to your satisfaction.

           

          Regards,

          Mike Tarallo

          Qlik

            • Re: Qlik Sense Server - User Access Pass
              Nico Manro Oberholzer

              Hi Michael,

               

              I've watched that video multiple times. Doesn't work for me... Hence why i turned to the community.

               

              Thanks anyway,

              Nico

                • Re: Qlik Sense Server - User Access Pass
                  Michael Tarallo

                  Hey Nico,

                   

                  Quick question - is this a trial of Qlik Sense Enterprise or did you pay for some tokens? If the latter I assume you can open a case with Qlik Support and troubleshoot. That is always an option.

                   

                  In order to troubleshoot this we need more information from you. Without that info, we can only assume and start with the basics. Your error indicates that the id you are logging in with does not have a "login" or "user" access pass. Can you show me the list of the user IDs you have in the user panel and the uses you have assigned / allocated?

                   

                  It may be that you have 2 of the same ID - this is common - one has the directory name of the computer and the other has the directory name of the domain.

                   

                  so you either login as - mtarallo

                   

                  or domain\mtarallo

                   

                  These would be considered 2 different IDs and perhaps the one you are using does not have the access pass assigned.

                   

                   

                  The other thing you can do - is assign a generic access rule to allow everyone in:

                   

                   

                  This will allow everyone to login, at least to test your setup.

                   

                  let us know.

                   

                   

                  Please mark the appropriate replies as CORRECT / HELPFUL so our team and other members know that your question(s) has been answered to your satisfaction.

                   

                  Regards,

                  Mike Tarallo

                  Qlik

                    • Re: Qlik Sense Server - User Access Pass
                      Nico Manro Oberholzer

                      Hi Michael,

                       

                      Now something weird is happening...

                       

                      1. If I try to log into the HUB from the get go, i get the generic "you have no access pass".

                      2. I can however access the QMC from the client machine (see attached).

                      3. If i then go into the servername/hub then i have access to the hub with the user that i used to sign into the QMC in point no.2?? (see attached)

                      4. If i then logout from the QMC, and try the same as in Point no.3, the its the same "no access pass" issue.

                       

                      Just as a side note: The client machine that im using to log into the Hub is connected to the company network via a VPN connection. The client machine (my machine) is not directly connected to the server.

                       

                      The idea is to have the authentication run at point of loading the HUB in the browser?

                       

                      I'll respond to your above mentioned response shortly.

                       

                      Capture3.JPG

                       

                       

                       

                      Capture2.JPG

                      • Re: Qlik Sense Server - User Access Pass
                        Nico Manro Oberholzer

                        Regarding your initial response.

                        It is a trail lic.

                        The setup is currently using the access rule to allow anyone access (like *), but still no win.

                         

                        The users:

                        Capture5.JPG

                        Capture4.JPG

                        • Re: Qlik Sense Server - User Access Pass
                          Nico Manro Oberholzer

                          Hi Michael,

                           

                          I've just realised. The setup is fine. And the user to whome i have assigned access have access via the hub. But only after the authentication has taken place.

                          12.JPG

                          But his authentication is only requested from the servername/qmc link. It does not request for the same authentication from servername/hub link? Why would that be?


                          How can i force the system to prompt for the user authentication at logon? I get the same error when accessing the hub via mobile (android). However, again when going to QMC first, i get the login prompt.

                          Screenshots_2015-07-28-17-48-22.png

                          Any idea what might be causing this? Or how to get the Authentication Prompt when loading the server/hub?


                          Regards,

                          Nico

                    • Re: Qlik Sense Server - User Access Pass
                      Nico Manro Oberholzer

                      Hi Micheal,

                       

                      As mentioned above. I sorted out the Access Passes by virtue of not allowing anon access.

                       

                      However, now something wierd has happended. We've baught the tokens. I've added the users allocation passes and now, even with the access passes none of those users can access the Hub? All can access the QMC but none of them can get into the Hub... I have no clue what to do now?

                      Acess.png

                      Pleas help?