2 Replies Latest reply: Jul 31, 2015 10:00 AM by Lucas Marsola RSS

    Dúvida Seleção/Filtragem

    Lucas Marsola

      Bom dia!

      Estou com uma dúvida do motivo do Qlikview se comportar desta forma e gostaria de saber se alguém poderia me ajudar.

      Fiz uma seleção em meu filtro de Cliente, selecionando apenas um cliente:

      1.png

      Como era o esperado, como há apenas um valor possível para a Curva ABC, Segmento, Cidade e Estado, o Qlikview já mostra para mim estes valores nos respectivos filtros, como podem ver.

      Entretanto, para o Representante, também há apenas um valor possível, veja que há apenas um valor em branco:

      2.png

      Mas como podem ver na primeira imagem, o Representante não está aparecendo automaticamente como os outros campos.

      Alguém sabe por que isto acontece? É alguma configuração?

       

      Obs1: Representante não está na mesma tabela que Cliente.

      Obs2: Curva ABC, Segmento, Cidade e Estado estão na mesma tabela que Cliente.

      Obs3: A modelagem está em Star Schema.

       

      Agradeço pela ajuda!

      Lucas

        • Re: Dúvida Seleção/Filtragem
          Johnatan Guimaraes

          Creio que deve ter algum valor Nulo no campo Representante. Tenta abrir o visualizador de tabelas da sua aplicação e verifica na tabela que se encontra o campo Representante se a proporção de subconjunto está em 100%. Se não estiver 100% creio que a resposta seja isso: Não existe a relação desse campo para todos os campos possiveis seleceionados, assim gerando valores nulos para o campo selecionado, e isso proporciona a sua dúvida de deixar o campo em branco como se houvesse mais seleções para ele.

           

          Conseguiu entender?