0 Replies Latest reply: Aug 19, 2015 5:26 AM by Patric Amatulli RSS

    Qlikview Extension - SelectTextsInColumn

    Patric Amatulli

      Hi folk,

       

      I am encountering a problem when I try to select multiple values in multiple fields via extension.

      The problem is that for the first 2 fields it is working fine, but when it comes to the 3thd field i get an updating message error from qlikview:

      UDATING TRY AGAIN message....Is it going to fast? How I can avoid such behaviour?

      Is there a limitation when I try to select multiple fields value from an extension, where multiple means >2 fields.

       

      Thanks for your help!

       

      This is the snippet .js code which I use for that purpose:

       

      //PAM: Parse QvKey, and set Selection based on the Dimension behind the extension

                  for(var i=0; i< splitted.length-1; i++){

                    

                      //PAM: Split Key and Values

                      keyEntry =splitted[i];  

                      pos = splitted[i].indexOf(':');

                      selectedValues = keyEntry.substring(pos+1);

                      selectedField =  keyEntry.substring(0, pos);          

                    

                      //PAM: Loop the dimensions setting in the extension              

                      for(var j=0; j< _this.Data.HeaderRows[0].length-1; j++)

                      {  

                          //PAM: Check if the KeyField is equal to the dimension field

                          if(selectedField==_this.Data.HeaderRows[0][j].text){

                              //PAM: Apply selection, whereby the Values have to be converted into an array for multiple values selection

                               _this.Data.SelectTextsInColumn(j, true,valuesToArray(selectedValues));

                               //HERE I APPLY THE SELECTION IN QLIK!                       

                              break;

                          };  

                      }                  

                  }