2 Replies Latest reply: Sep 17, 2015 10:24 AM by Daniel Kay RSS

    NuGet Package

      Is there any reason why the QlikSense nuget package requires specific versions of it's dependencies?

       

       

      Especially the JSON element, there is that many libraries, including Microsoft's own libraries that use it your almost destined to get a dependency conflict...

       

      For instance:

       

      Unable to resolve dependencies. 'Newtonsoft.Json 7.0.1' is not compatible with 'Microsoft.Owin.Security.OAuth 3.0.1 constraint: Newtonsoft.Json (≥ 6.0.4)', 'QlikAuthNet 1.1.1 constraint: Newtonsoft.Json (≥ 6.0.0)', 'QlikSense.NetSDK 2.0.3 constraint: Newtonsoft.Json (= 6.0.3)', 'Westwind.Globalization 2.1.0 constraint: Newtonsoft.Json (≥ 6.0.8)', 'Westwind.Web 2.64.0 constraint: Newtonsoft.Json (≥ 6.0.8)'.