9 Replies Latest reply: Nov 11, 2015 7:29 AM by Fabian Jaehn RSS

    NPrinting only applies recipient filter to one connection

    Fabian Jaehn

      Hello,

       

      I have 2 connections added to my NPrinting report: Contracts and Sales.

       

      From the first one, Contracts, I generate HTML reports and embed them directly to the email body. Each recipient has a personal filter (under the mapping field in Recipient Import Task 'Filter 1'). This filter applies a region to each recipient and then they receive a customized report.

      So far so good - that works very well.

       

      Now I want to attach an Excel file with Sales data (= from the other connection) - again personalized by the recipient filter.

       

      The attaching and creation of the Excel file works fine - however - it doesn't apply the recipient filter anymore.

       

      I can also verify this when I add %%Recipient_Current_Selections%% to the email body. That lists which filters have been applied to what connection - and the recipient filter is missing from the Sales connection.

       

      Does anybody know how I can apply the recipient filter to all connections? I tried already Linked Fields but that didn't work (but maybe I did something wrong).

       

      Thanks a lot.

       

      Fabian

        • Re: NPrinting only applies recipient filter to one connection
          Adam Krepistman

          Fabian

           

          when you say you are attaching the Excel file, is that something that is already crated or are you generting it in NPrinting?

           

          Is this where you have 1 nsq with 2 connections and 1 report from each connection.

           

          You have tried what I would have suggested - linked fields but does each connection/qvw have a field that represents the personal filter? If so you will need to create a new field by linking the 2 fields together and then using that new field as a filter?

           

          Is it safe to assume both of these reports are using the same distribution list?

           

          can you post the qvw and nsq?

            • Re: NPrinting only applies recipient filter to one connection
              Fabian Jaehn

              Thanks Adam for your reply.

               

              I'm quite sure I need to use a Linked Field but have just used it incorrectly.

              Can you explain what you mean by "... you will need to create a new field by linking the 2 fields together and then using that new field as a filter?" <- how can I create that new field? Do I do that in NPrinting through a Linked Field?

              Here is what I tried: There is a field in both the 'Contracts' and 'Sales' connections/reports called 'office'. In the recipient list under the (later imported) column Filter, I have for each person something else, e.g. office={city1}.

              Then I created a Linked Field and added 'office' from both connections.

              Then I have added that Linked Field as a filter to the Task which sends out the email with attachment.


              But the filter is only applied to the 'Contracts' part - the filter used I think comes from the recipient import anyways.



              To answer the questions:

              Yes, I am creating the Excel file in NPrinting.

              Yes, 1 nsq with 2 connections. HTML reports are based on the 'Contracts' connection and the Excel report from the 'Sales' connection.

              Yes, the reports are using the same distribution list because I want to send the 'Contracts' part in the email body and the 'Sales' part as an Excel file attachment to that same email.

              No, unfortunately I cannot post the nsq nor qvw as there would be too much to blurr out.

            • Re: NPrinting only applies recipient filter to one connection
              Stephen Jasionowski

              Fabian -

               

              Are you setting up the equivalent filter for the Sales connection? You will need a filter for the regions that each recipient should see data for in both connections.

               

              Another way around this is to use a linked field. In this case, select the field name that represents the region from the Contracts connection and do the same for the Sales connections.

               

              Then give it a name that will make it easy for you to recognize later and choose between whether or not you want to keep matching values only (inner join) or all values (outer join).

               

              The linked field can now be used as for filtering, so create a new filter with the linked field and select the values. This will be applied to objects from both connections. It can also be used in your recipient import to assign filters to users.

               

              See this tutorial for more: How to Use Linked Fields with Keep All Matching Values Only – Customer Feedback for Vizubi