17 Replies Latest reply: Jan 20, 2010 7:30 AM by mauro marson RSS

    Failed to connect to command center

    vwalker

      Hi Everyone,

      I have a fresh install of QVS & QVP 8.5 on Windows Server 2003 64-bit but I can't get into the control panel. When I try to access http://localhost/controlpanel/default.aspx I get an error message stating "failed to connect to commant center at url: http://localhost:8084/qtcc.asmx. I can't determine the resolution to this issue. I have disabled soap extensions but it didn't make a difference. I can't get onto the qtcc.asmx page so I have tried changing the port from 8081 to 8084. ASP & ASP.NET are all enabled. The account belongs to Qlikview Administrators group. QVS seems to be working fine - I have no issues with accessing http://localhost/qlikview. Any ideas as to what could be causing this?? Full details of the error message included below.

      Thanks!

      Failed to connect to command center at url: http://localhost:8084/qtcc.asmx.

      This error might occur when having soap extensions enabled while running on a double byte language OS.
      To disable soap extensions. Edit web.config and set EnableSoapExtensions to False

      Extended technical information is:

      Exception details

      System.InvalidOperationException: Unable to generate a temporary class (result=1). error CS2001: Source file 'C:\WINDOWS\TEMP\ap09zelh.0.cs' could not be found error CS2008: No inputs specified at System.Xml.Serialization.Compiler.Compile(Assembly parent, String ns, XmlSerializerCompilerParameters xmlParameters, Evidence evidence) at System.Xml.Serialization.TempAssembly.GenerateAssembly(XmlMapping[] xmlMappings, Type[] types, String defaultNamespace, Evidence evidence, XmlSerializerCompilerParameters parameters, Assembly assembly, Hashtable assemblies) at System.Xml.Serialization.TempAssembly..ctor(XmlMapping[] xmlMappings, Type[] types, String defaultNamespace, String location, Evidence evidence) at System.Xml.Serialization.XmlSerializer.GetSerializersFromCache(XmlMapping[] mappings, Type type) at System.Xml.Serialization.XmlSerializer.FromMappings(XmlMapping[] mappings, Type type) at System.Web.Services.Protocols.SoapClientType..ctor(Type type) at System.Web.Services.Protocols.SoapHttpClientProtocol..ctor() at CPGlobal.CommandCenterWebService.CommandCenterWebService..ctor() at CPGlobal.ServicePool.CommandCenterWebServiceUnAuthorized() at CPGlobal.ExtendedAuthenticatedRole.AuthorizeMe()

        • Failed to connect to command center
          Karl Humma

          Just to be sure, have you restarted the commandcenter service after changing the soap extension settings? Or rebooted the server?

          Can you also check the event logs >application and see if there is any more info in there.

           

          Thanks.

          /Karl

            • Failed to connect to command center
              vwalker

              Hi Karl,

              I have restarted / rebooted like there is no tomorrow, but no luck. Also don't see much logged in the event viewer - mainly just logs from restarting the services.

              I'm not sure what I did, but I seem to be getting a slightly different message now - included below. Does it make sense that it is saying target machine is refusing connection when I am trying to connect to localhost?

              Thanks

               

              Failed to connect to command center at url: http://localhost:8084/qtcc.asmx.

              This error might occur when having soap extensions enabled while running on a double byte language OS.
              To disable soap extensions. Edit web.config and set EnableSoapExtensions to False

              Extended technical information is:

              Exception details

              System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:8084 at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress) at System.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP) at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception) --- End of inner exception stack trace --- at System.Net.HttpWebRequest.GetRequestStream() at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at CPGlobal.CommandCenterWebService.CommandCenterWebService.CheckPrerequisites(String Cert) at CPGlobal.ExtendedAuthenticatedRole.AuthorizeMe()

            • Failed to connect to command center
              vwalker

              I've done some more digging on this, and it appears as though the server is not listening on either port 8081 or 8084. Does anyone have any suggestions on how to resolve this?

              Thanks

                • Failed to connect to command center
                  Rob Wunderlich

                  I had s similar issue installing V9 the other day. In that case, the service would start but the TCPIP listener was never established. There were no error messages in the Event log. The messages I needed to eventually solve the problem were in the CommandCenter log at

                  C:\Documents and Settings\All Users\Application Data\QlikTech\Publisher\CommandCenter\Log

                  Have you checked that log for errors or other clues?

                  -Rob

                   

                  • Failed to connect to command center
                    Karl Humma

                    Are you running any firewalls on this machine or antivirus, like mcafee? If you have a firewall make sure you have the ports open. If you are running any antivirus make sure they are not using the same ports.

                     

                    hope this helps!

                    /Karl

                  • Failed to connect to command center
                    softsystems
                    In services, all qlikview services are running?Look this, ok?!I had the same message, put QlikView my services were not started after have installed Publisher. Just restart should resolve them, it also restart IIS.

                    Eu tive uma mensagem igual, porem meus servicos qlikview nao estavam iniciados apos ter instalado Publisher.Apenas reinicia-los deve resolver, vale reiniciar o IIS também.