5 Replies Latest reply: Jul 20, 2009 5:33 PM by emre cabuk RSS

    Blackberry no file access

      I try to get a hello world qlikview working on my blackberry storm after installing qlikview 9 yesterday. I keep geting the 'no file access' error or if use authentication i get a null error value.

      The debug mode on the blackberry shows some information but it doesn't mean anything to me.

      Some questions i have:
      - can i get this working with qlikview 9 server without a qlikview publisher license?
      - if i use the same username in the auth parameter from the blackberry java app, on iis for anonymous access and on NTFS file permissions is that the way to go?

      I see the hello world qlikview listed on my blackberry and also other files, that part works correct.

      When i turn off authentication in the java app the logfile on program data/qliktech/qvc/events shows:
      "Warning The document d:\qlikview\Mobile\hello_world.qvw failed to load because anonymous access is not allowed" The blackberry shows "no file access"

      If i use authentication like mentioned above the logfile shows an error:
      "Warning The document d:\qlikview\Mobile\hello_world.qvw failed to load because anonymous access is not allowed" and the blackberry shows "Error - Null'

      When i try to allow anonymous authentication in the enterprise management console the setting will not save. I click apply and the setting goes back to prohibit anonymous authentication.

      Thanks in advance!

        • Blackberry no file access

          Is nobody usings blackberries to get access to their company data? Perhaps i didn't explain the problem very clear?

          Please help! Smile

          • Blackberry no file access
            Karl Humma

            There is an issue, sometimes, with the management console not saving these selections. I have done this workaround to make it anonymous:

            1) start >run> regedit goto My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\QlikTech\QlikViewServer\Settings 7

            2a) Set the AuthenticationLevel string value to 0.

            2b) If the AuthenticationLevel String Value does not exist create a string value name it AuthenticationLevel and set it to 0.

            3) Now go to start >run >services.msc and restart the QlikView Management Service service.

            -This will set the Security tab for clients to Always Anonymous, located in your Q(E)MC >System >Setup >Qlikview Servers > click your QVS server and go to the Security tab under Authentication >Clients.

            4) Next in the Q(E)MC >System >Setup >Qlikview Web Services section click on your QVWS >AccessPoint tab and for Authentication set it to Never and click Apply (twice). This should do the trick, let me know if this fixes or at least gets you any closer.

            /Karl

              • Blackberry no file access

                Hi Karl,

                I tried your solution. I found that this registry key exists. I changed the value to 0, after a restart of the qlikview management service and a refresh of the regedit screen, the value immediately changed back to 2 again Tongue Tied I didn't do anything else in between these 2 steps (the same for value 1 instead of 0). It looks like i simply can't choose anonymous for some reason?

                I was thinking is there a link with the dynamic user cal addition perhaps?

                Another thing i noticed was that there is no "Auth URL" configured on my blackberry app.

                Arjan

                  • Blackberry no file access
                    Karl Humma

                    Ok I think I know what the issue is here. Do you have either of these as a Server License type:

                     

                    Small Business Edition

                    QlikView Server Small Business Edition (SBE) is available for customers

                    looking for a QlikView Server specifically designed to support a smaller

                    organization.

                    QlikView Server for Community

                    QlikView Server for Community (Q4C) is available for customers looking

                    for a QlikView Server with a limited number of documents and a limited

                    number of known users.



                     

                    This would explain why you can't change to anonymous. In this case you will have to use some form of security which is explained more in Part IV:QLikView Server, section 16.2 of the QlikView Server Reference Manual.

                     

                    Hope this helps.

                     

                      • Blackberry no file access
                        emre cabuk

                        hello Karl,

                        I have the same problem in java mobile. I have tried your solution on enterprise Qlikview server 8.5 . but this "null" error changed to no user access even I set the authentication method to anonymous. what is the config parameters for Auth Url regarding the one of the java mobile documentation.??

                         

                        thanks

                         

                        Authorization

                        If authorization is enabled in the setup screen the mobile client will ask for username and password. It

                        will then try to get a ticket from the url set up in the config parameters. For this to work the server must

                        be configured to accept basic Http authentication.