9 Replies Latest reply: Mar 30, 2011 4:37 PM by bmeissner RSS

    Qlikview Server install Problems

    Tyrone Fay

      Hi

      I wondered if anybody has had the same problems that I am currently having. Have been using QlikView 8.5 for a while with no problem, went to upgrade it to version 9. So I uninstalled version 8.5 and went to install 9, but for some reason the install will not work. Its in what looks like the final stages of registering modules when it starts to rollback and all it leaves me with is this message (if I turn on the log while installing):

      MSI (c) (48:DC) [09:51:09:359]: Windows Installer installed the product. Product Name: QlikView Server . Product Version: 9.0.7119.4. Product Language: 1033. Installation success or error status: 1603.

      Does anybody have any thoughts for me? Thanks if you do,

      Tyrone

        • SV:Qlikview Server install Problems

           

          Haven't installed v9 but here is what error status 1603 says:

          http://support.microsoft.com/kb/834484

          //Michael

          • Qlikview Server install Problems

            Hi

            Could u please let me know wat all steps u followed to Install

              • Qlikview Server install Problems
                Tyrone Fay

                After having problems I reduced myself to a fairly simple install to see if this would allow me to install the application... so when asked I have said the following:

                • Install for everybody on the computer
                • Change the install directory to D:\Program Files\QlikView\ (tons of space here)
                • Tick "install typical components"
                • Specify the account to run the services as and use the Admin account for the server

                I then click on Next and it all goes well and it gets past "Register QVB" and it starts to register modules and at this point it starts to roll back. Sadly this happens so fast that I cannot see what it is trying to register when it falls over. Therefore I installed the application and turned on the logging to * (which I think should cover everything)

                This gives me lot of information which ends like below... but even in this I cannot see anything that seems to be causing the problem:

                Property(C): PrimaryVolumeSpaceAvailable = 381964768
                Property(C): PrimaryVolumeSpaceRequired = 480464
                Property(C): PrimaryVolumeSpaceRemaining = 381484304
                Property(C): WISEVIRTUALDIRECTORY1_VIRDIR_NAME = QlikView
                Property(C): WISEVIRTUALDIRECTORY1_VIRDIR_NAME_CHILD = QlikView
                Property(C): WISEVIRTUALDIRECTORY2_VIRDIR_NAME = QvJava
                Property(C): WISEVIRTUALDIRECTORY2_VIRDIR_NAME_CHILD = QvJava
                Property(C): WISEVIRTUALDIRECTORY4_VIRDIR_NAME = QvPlugin
                Property(C): WISEVIRTUALDIRECTORY4_VIRDIR_NAME_CHILD = QvPlugin
                Property(C): WISEVIRTUALDIRECTORY7_VIRDIR_NAME = QvAjaxZfc
                Property(C): WISEVIRTUALDIRECTORY7_VIRDIR_NAME_CHILD = QvAjaxZfc
                Property(C): WISEVIRTUALDIRECTORY9_VIRDIR_NAME = QvClients
                Property(C): WISEVIRTUALDIRECTORY9_VIRDIR_NAME_CHILD = QvClients
                Property(C): WISEVIRTUALDIRECTORY5_VIRDIR_NAME = Scripts
                Property(C): WISEVIRTUALDIRECTORY5_VIRDIR_NAME_CHILD = Scripts
                Property(C): WISEVIRTUALDIRECTORY3_VIRDIR_NAME = QvAnalyzer
                Property(C): WISEVIRTUALDIRECTORY3_VIRDIR_NAME_CHILD = QvAnalyzer
                Property(C): WISEVIRTUALDIRECTORY8_VIRDIR_NAME = QvPrint
                Property(C): WISEVIRTUALDIRECTORY8_VIRDIR_NAME_CHILD = QvPrint
                Property(C): WISEWEBSITES_TCP_PORT = 80
                Property(C): WISEWEBSITES_SSL_PORT = 0
                Property(C): WiseOsqlCmd = d:\Program Files\Microsoft SQL Server\90\Tools\Binn\Osql.exe -L
                Property(C): PrimaryVolumePath = D:
                Property(C): WiseCurrentDialog = Start_Installation_Dialog
                Property(C): ALLUSERS = 1
                === Logging stopped: 26/07/2009 09:51:09 ===
                MSI (c) (48:DC) [09:51:09:359]: Product: QlikView Server -- Installation operation failed.

                MSI (c) (48:DC) [09:51:09:359]: Windows Installer installed the product. Product Name: QlikView Server . Product Version: 9.0.7119.4. Product Language: 1033. Installation success or error status: 1603.

                The install file QvsSetupRedist.exe is on the local drive of the server so there should not be any communication issues or problems such as this.

                To be honest I am at a slight loss.

                Hope the above helps to show what I am doing (and maybe doing wrong),

                Tyrone

              • Qlikview Server install Problems
                Steve Dark

                Hi Tyrone,

                My server upgrade went reasonably smoothly, but I have heard it said that when you uninstall 8.5 server to upgrade to 9 you should make sure you have cleared all traces of 8.5. This includes deleting any folders with settings and log files, and deleting any registry keys.

                Can you try installing it on a different server?

                I believe they are planning to improve the installer for the v9 server component, so that it is a bit more tollerant of left over 8.5 settings.

                Cheers,
                Steve

                  • Qlikview Server install Problems
                    Tyrone Fay

                    Hi,

                    I went and removed all the folders I could find (including the one under all users) went through the registry and rebooted the server. Tried another install and still no joy... though I do now think that it is having problems registering QlikViewXYZ.dll (if this is what my eyes saw as the last thing before rollback).

                    Thanks for the advice, suspect this is not going to be my week :)

                    Tyrone

                      • Qlikview Server install Problems
                        Tyrone Fay

                        I have also tried to install this application on another server and got the same problem... the servers are setup differently as well... so really confused about this now.

                        Tyrone

                          • Qlikview Server install Problems
                            Tyrone Fay

                            Hi

                            I got this (below) back from QlikTech which for me is the answer :)

                            Thanks to all who responded to me.

                            A machine that is disconnected from the domain may not be able to authenticate a user during the installation process (when selecting which account should run the services), if the user falls back, and un-checks the box allowing the installation packet to continue to install the services to run as local system, it will in fact install them to run as the user which was tried, but denied... because this user was not authenticated, no service will start until passwords are supplied in the service properties pane.

                            At times, the installation packet will not let one set a local administrator account as the account to run the services, the work around is to deselect the checkbox and install the service to run as local system (note above problem). This is considered to be a WAD: 21845.

                            Tyrone

                              • Qlikview Server install Problems
                                bmeissner

                                I'm having the same issue when I try to install V10 onto a machine that had V9. I uninstalled V9, downloaded the V10 SR1 software and tried to run. I get through most of the install and then it rolls back. I already tried checking the box to assign the user ID for the services later, but it still won't work. Also, the server is connected to the domain. Any idea where I can find any registry keys that may be tripping me up?

                                Thanks,

                                Bret