1 Reply Latest reply: Dec 18, 2015 5:05 AM by Hakan Ronningberg RSS

    SAP Connector 6.1.1 Error (QVX_PIPE_ERROR)

    Jan Kammers

      Hello everyone,

       

      I've upgraded from SAP Connector 5.8 to 6.1.1.

      Since then I'm getting following error when I try to load certain Date-Fields from SAP (EWM) :

       

           Error: QVX_PIPE_ERROR: The value '11.05.2015 10:26:46' could not be converted to type double

       

       

      I'm getting Data from SAP (as seen in SAP-Connector-log):

       

      16:18:25,928 [4] - Connection to SAP verified

      16:18:25,928 [4] - SAP Transport information: version: E6DK900758; date: 2015-12-01; time: 15:58:17; SAP basis: 702;

      16:18:25,990 [4] - SqlDataService.GetData() - About to invoke function: /QTQVC/FETCH_STREAM

      16:18:26,052 [4] - SqlDataService.GetData() - read 293 data rows.

      16:18:26,084 [4] - SqlDataService.GetData() - read 293 data rows.

      16:18:26,099 [4] - SqlDataService.GetData() - read 293 data rows.

      16:18:26,130 [4] - SqlDataService.GetData() - read 293 data rows.

      16:18:26,162 [4] - SqlDataService.GetData() - read 293 data rows.

      16:18:26,193 [4] - SqlDataService.GetData() - read 293 data rows.

      16:18:26,208 [4] - SqlDataService.GetData() - read 1 data rows.

      16:18:26,271 [4] - SqlDataService.GetData() - Fetch completed successfullly, received all 1759 rows sent from SAP.

       

      Is this a Connector-configuration problem or do I need to change settings / column types in SAP?

        • Re: SAP Connector 6.1.1 Error (QVX_PIPE_ERROR)
          Hakan Ronningberg

          Hi Jan,

           

          The SQL connector of release 6.1.1 uses a new framework on the Windows side compared to release 5.8. The Timestamp in your example is stored with datatype 'decimal' is SAP. The new framework expected a decimal field being sent from SAP. However there is a conversion routine on the SAP side which formats the value like 11.05.2015 10:26:46.

          This is not a decimal field anymore and the connector failed. The connector of release 5.8 did not care about the datatype used and hence it did not fail.

          The solution in the next release of the SAP connectors will be not to format the field before sending it to the Windows part of the connector. There are many possibilities to format the field in QlikView and Qlik Sense instead.

          If this is an urgent problem, please contact the Qlik Support. They can provide a patch which has the solution described above implemented.

           

          Regards,

          Hakan