4 Replies Latest reply: Oct 22, 2009 5:03 PM by tatierney RSS

    Version 9.1 and IIS

      I know the default install of version 9.1 uses the QlikView Web Server, but I was wondering if there was anyone out there who has installed the IIS virtual directories (You have to actually select this activity during the install). More specifically, I'm looking for anyone who has any additional knowledge with section 4.4 (p. 45) in the manual. I'm a little unsure what to do during step 6.

      thanks,

      rob

        • Version 9.1 and IIS
          Community Administrator

          Rob,

          Just to clarify, the latest public release is 9.0 SR1, not 9.1...unless you have some secret version even I am unaware of! Stick out tongue

          • Version 9.1 and IIS
            Björn Wedbratt

            hi Rob,

            I don't have the manual infront of me right now, but basically what you need to do to get full IIS support in QVS 9.0 SR1 is:

            - Install with the IIS option selected during installation. You also need to install QVWS, but you can disable it later on.

            - Verify that virtual folders are created in IIS. If not, check the installation log

            - Create a new application pool in IIS. Change the identity of the pool to the same account used when installing QVS

            - Change the application pool for the virtual folder /QvAJAXZFC from "Default AppPool" to the one created above.

            - Open QEMC or QMC and locate your settings for AccessPoint (under QlikView Webserver Service).

            - Change the URL for Accesspoint to AccesspointSettings.aspx located in /QvAJAXZFC (so the URL would be similar to http://localhost/QvAJAXZFC/AccesspointSettings.aspx)

            - Shut down QVWS (Set it to manual restart as well).

            The reason why QVWS needs to be installed is that settings for AccessPoint will still be written to config.xml in the QVWS app-folder (not program-folder).

            Note: if you need support to tunnel over http/https with plugin/java you also need to configure the QVS Tunnel ISAPI dll in IIS. QVWS is handling tunneling by default, so it won't be available if you turn QVWS off.

              • Version 9.1 and IIS

                I was successful at configuring IIS when installing the 32 Bit QV9 SR1 version on a 32 OS but cannot get the 64 Bit version of QV9 SR1 working on a 64 Bit OS.

                Needless to say I have installed/uninstalled more times than I care to mention. In both cases above the QV9 install didn't create the website or virtual directories required by the QV Management tools. The install does successfully create the virtual directories under the Default Web Site in IIS for the clients. [QvClients, QvJava, QvAJAXZfc and QvPlugin etc].

                To get the 32 bit environment working I simply created a new website on port 4780 in IIS then created the 3 virtual directories under this for 'QEMC', 'QMC' and 'QMCCommon'. The QV Management tools then worked without a problem using http://localhost:4780/qemc/default.aspx and I could register/licence the software etc

                The same workaround does not work on the 64 Bit version. The Management console loads and I can see the Green borders, tabs, buttons & graphics but there is no content in the main part of the screen. Just the windows egg timer.

                I used 'Fiddler' to inspect the HTTP traffic and this revealed that the console website files [QEMC] was trying to locate a 'QvAJAXZfc' directory and content under the 'QMCCommon' virtual directory. When I manually copied the contents across it simply resulted in the following XML error message.

                <?xml version="1.0">?

                <result><message text="Unknown kind"/></result>

                I also tried creating the virtual directories required by the management console under the Default Web Site and accessed via port 80. The result was the same however.

                When I installed QV9 I wasn't asked any specific up-front questions about IIS support. Instead I selected a custom install and made sure that the IIS files were set to 'Will be installed on the local hard drive'. (as opposed to 'feature will be installed when when required' or 'entire feature will be unavailable')