3 Replies Latest reply: Dec 18, 2015 12:53 PM by Dafnis X RSS

    SSO doesn't work when changing Excel to QVD

    Dafnis X

      Hi,

       

      We use SSO, where the users data are retrieved from Excel. Everything is running fine.

      I have created a QVD file based on the Excel. But, when loading the users data from QVD, the SSO doesn't work, and the user is prompt

      for the application user & password.

       

      Here is the script:

      Supps:
      LOAD ACCESS,
      USERID,
      PASSWORD,
      SERIAL,
      NTNAME,
      SUPPCODE
      FROM
      [..\..\Data\Suppliers\Final_Supp_QVD\TmpSupps.qvd]
      (
      qvd);

      Section Access;
      LOAD * INLINE [
      ACCESS, USERID, PASSWORD, SERIAL, NTNAME, SUPPCODE

       

        …..Deleted

          ];

      Concatenate

      LOAD

      ACCESS

      USERID,
      SERIAL,
      PASSWORD,
      NTNAME,
      SUPPCODE

      Resident Supps;
       

      Section Application;
       

      STAR is *;
      DROP Table Supps;


      Does anyone have an idea why using the QVD disables the SSO?


      Thsnks!

        • Re: SSO doesn't work when changing Excel to QVD
          Clever Anjos

          You can´t access a table from a Application Section inside a Section Access, your should move your qvd load to inside "Section Access"

           

          Supps:
          LOAD ACCESS,
          USERID,
          PASSWORD,
          SERIAL,
          NTNAME,
          SUPPCODE
          FROM
          [..\..\Data\Suppliers\Final_Supp_QVD\TmpSupps.qvd]
          (
          qvd);

          Section Access;
          LOAD * INLINE [
          ACCESS, USERID, PASSWORD, SERIAL, NTNAME, SUPPCODE

           

            …..Deleted

              ];

          Concatenate

          LOAD

          ACCESS,

          USERID,
          SERIAL,
          PASSWORD,
          NTNAME,
          SUPPCODE

          Resident Supps; // This will not work because this table was created outside Section Access

          Section Application;

          STAR is *;
          DROP Table Supps;

            • Re: SSO doesn't work when changing Excel to QVD
              Dafnis X

              Hi,

               

              I had to do that after receiving general script error..

              I can't understand why..

               

              Thanks!

               

              17/12/2015 18:42:26: 0065  Concatenate

              17/12/2015 18:42:26: 0066  LOAD ACCESS,

              17/12/2015 18:42:26: 0067       USERID,

              17/12/2015 18:42:26: 0068       PASSWORD,

              17/12/2015 18:42:26: 0069       SERIAL,

              17/12/2015 18:42:26: 0070       NTNAME,

              17/12/2015 18:42:26: 0071       SUPPCODE

              17/12/2015 18:42:26: 0072  FROM

              17/12/2015 18:42:26: 0073  [..\..\Data\Suppliers\Final_Supp_QVD\TmpSupps.qvd]

              17/12/2015 18:42:26: 0074  (qvd)

              17/12/2015 18:42:26:       6 fields found: ACCESS, USERID, PASSWORD, SERIAL, NTNAME, SUPPCODE, General Script Error

              17/12/2015 18:42:26:       Execution Failed

              17/12/2015 18:42:26:      Execution finished.